PDA

View Full Version : computer not reading audio cds



shtngstrz
07-28-2005, 12:03 PM
My computer will not recognize audio cds. I tried to burn a cd and it says that there is no disc in the drive or it comes up with an error-unsuccessful burn. I put in an installation cd for a program and it works fine- the setup box appears on the screen. I tried to play a cd that has not been burned and it will not recognize it. I recently had my computer fixed at a shop. Could something have happened there or is there something wrong with my drive? Any advice is appreciated. Thanks.

GSV3MiaC
07-28-2005, 12:40 PM
Right click the drive icon in 'my computer' and check what you have set up for the 'autoplay' options (one of the tabs will display that). Check the other tabs and make sure you've got no strange options set.

If the drive works OK for reading a software CD, it should read a music CD too. Burning one is another matter, but I doubt it's a hardware problem. Worst case, ask the shop what they broke when they had it in for repair...

shtngstrz
07-28-2005, 01:19 PM
The "autoplay" is set to "music files". Also, all the drives under Hardware say they are working properly.

LtData
07-28-2005, 04:43 PM
Try holding the left shift key whenever you insert an audio CD and for about 10 seconds aftwards and see if it still does it. What the shift-key does is temporarily disable autoplay, as it sounds like some program is autolaunching to keep you from ripping these CDs. You didn't try to rip a copy-protected CD at some point, did you?

shtngstrz
07-28-2005, 05:05 PM
That doesn't work either. The only difference is that the cd picture appears next to my cursor for a couple seconds and then goes away. It wasn't doing that before. As far as burning, I have tried several blank cd's from two different new packages and nothing works.

LtData
07-28-2005, 05:27 PM
Try going into your System Properties into Device Manager and uninstalling your troubling optical drive. Then, go to "Scan for hardware changes" and it should pick the drive back up. I think that option is under "Action" or mabye "View", I can't remember.

GSV3MiaC
07-28-2005, 06:36 PM
The "autoplay" is set to "music files". Also, all the drives under Hardware say they are working properly.

That's just the first drop down menu - when that one is selected you have also to tick one of the available options from the list below (or the box that says 'always ask me').

You should be able to change the drop-down menu to things other than music files, and select an autoplay action for each of those too (the bottom item should be 'blank CD').

Also check the =other= tabs on the device to make sure nothing weird has grabbed the drive (some packet writing software can have strange effects).

Spoon
07-29-2005, 03:48 PM
Perhaps the drive is broken, or it is a bad CD?

shtngstrz
07-29-2005, 06:16 PM
I'm taking it back to the shop because it worked before it went in and nothing I do to it makes it work. I find it hard to believe that it just suddenly broke, especially because software cds work.

LtData
07-29-2005, 11:33 PM
Wait, idea
Go into the drive's properties and make sure "Digital Audio" is on.
It should be in the drive's properties in Device Manager.
Also, while your there, check the IDE/ATAPI controllers to make sure DMA is enabled on all drives, Primary Channel and Secondary Channel.