PDA

View Full Version : .asx to .mp3?



Guest1
07-26-2005, 05:32 PM
I have the URL from the asx file. ( http://198.64.136.24:80/2544.asf ) It won't open in Windows Media Player and I get an error message that reads: "Windows Media Player cannot play the file. The Player might not support the file type or might not support the codec that was used to compress the file." Is it even possible to convert this? I downloaded dBpowerAMP Music Converter (dMC), but I don't get what to do next.

LtData
07-26-2005, 06:09 PM
If WMP can't play the file, you might be out of luck. Can you download the file it links too?

Guest1
07-26-2005, 06:36 PM
It just saves as an asx. The only time it works in WMP is when I open the file directly from the site.

Guest1
07-26-2005, 08:07 PM
I tried downloading it from the link, and it will open without the error message. There must be something different about the files though. The old one wasn't replaced by the newer one and they have the same name. Everything appears to be the same.

LtData
07-26-2005, 08:33 PM
They have different extensions, that's why the new one didn't overwrite the old one. Try launching the new file, as it should be a .asf file. How big is it?

Guest1
07-26-2005, 08:46 PM
It's only 52 bytes (same as the first one). I'm pretty sure it still has the same extension.

LtData
07-26-2005, 09:17 PM
Try opening the new file up in Notepad and see where it points to. It sounds like it is still a meta-file.

Edit: moved to dMC Support

Guest1
07-26-2005, 09:56 PM
[Reference]
Ref1=http://198.64.136.24:80/2544.asf


It's still the same I think, but I didn't get the error message. That's confusing. Now that the .asx is working with WMP, am I able to somehow convert it to .asf or another audio file?

LtData
07-27-2005, 06:17 AM
If the file itself contained video, you might have been able to rename it to .wmv and then have dMC pull out the audio and convert it.
However, since it is still a meta-file, you will have to use Auxiliary Input. Instructions below.

ChristinaS
07-27-2005, 01:17 PM
It's an audio file and I can play it in WMP. Probably the user needs to enable proper settings in WMP to play asx files. That's in Tools > Optins > File types and enable .asf .

ASX is a meta file. The uderlying asf file seems to be again a meta file pointing to itself, so you cannot download it using normal means.

Use the SDP program from http://sdp.ppona.com/ and use it to capture this file instead: http://198.64.136.24/2544.asf

Notice it's the url you gave minus the portion :80

This resulted in my being able to actually save the true asf file to my hard disk, which is 118Kb.

Guest1
07-27-2005, 04:00 PM
Thanks for the help, but I'm going to give up on this. The dMC Auxiliary Input keeps crashing when I'm trying to use it, and the program that ChristinaS mentioned won't install because the I'm missing Ntvdm.exe and I don't have the window install cd to install it.