View Full Version : Drive is not ready, Disk not written

06-02-2005, 09:04 PM
Getting error, The cd drive is not ready The disk is not written.

After that I must restart to get the disk out of the tray, and it indeed has not been written on at all.

Newly installed Plextor PX-716A
(Old drive worked perfectly)
Other apps write Data and music cd's.
Win XP Pro SP2
Version 2 CD Writer
(was using the old version, updating did not help)

dBpoweramp There is no better. Thanks for such a great software package.

06-02-2005, 09:35 PM
Right click that drive in My Computer and check to see if CD recording is turned on for the drive. This is the common problem after getting a specific form of spyware. It was the case for my brother's "bait-testing" computer.

06-03-2005, 04:22 PM
Yes. The CD recording was, and is, turned on for the drive. Thanks for the tip.

I have run aspi check even though I have read XP does not require it.
I have tried slow burn speeds.

The problem persists, other software continues to write cd/dvd normally.
I have upgraded to the new version, the previous version ran fine on the old drive. The only change made to the system was swapping the burners and removing one HDD. The DVD RW is on its own IDE channel, being Two. I'll review my jumper settings but I am 99.99% sure they are right. No other issues with any other apps or hardware.

Any and all suggestions are welcome.
Thanks in advance.

dBpoweramp is still the best software package on the planet. I would return this drive before I would use something else!

06-03-2005, 04:29 PM
What is the exact message shown?

06-03-2005, 04:38 PM
The header of the error box says,
dbPowerAMP CD Writer

The text says,
CD Drive Error "The drive is not ready"

Audio disc has not been written.

06-03-2005, 04:40 PM
Go to Device Manager.

Right click My Computer >> Hardware >> Device Manager

Uninstall that drive, reboot the computer and see if the problem persists.

06-03-2005, 04:52 PM
I did as instructed, windows found the drive on restart.

But the problem persists.

Further info...the drive does spin up for about three seconds.
After the error message if I manually eject the tray and insert new media the drive does not detect it, no spin up. The drive is "hung" at the point of the message. Restart required.

Thanks again Neil for trying.

06-03-2005, 04:52 PM
You may not need to reboot. After you uninstall the device, do Action --> "Scan For Hardware Changes" and it should detect your drive and re-add it.

Also, can other programs burn CDs?

06-03-2005, 04:54 PM
Other programs burn cd's data and music

06-03-2005, 04:54 PM
(This is strange.... LtData, d'you remember a similiar problem I had with my brother? We fixed it by.... Oh wait that was a different problem.)

EDIT: Saw your post. Ok, this is weird. I'm out of this. Moderators will help you.

06-03-2005, 04:59 PM
I can't really help anymore, as I haven't used the CD Writer before. Anyone else?

06-03-2005, 05:01 PM
I am considering digging up an old 4x cd-rw I still have. But it will probably work, and what would that prove? Also I got the latest flash upgrade from Plextor after the first burn attempt failed. This drive has never burned with poweramp. The app that does work is Easy cd/dvd and that was after getting the latest update, I did not try it before the update.

Thanks for the help!

EDIT: Saw your post Lt. Data, Thanks for trying. I was real excited to finally get a plextor drive. Real close to sending it back. I miss my TDK cd-r.

Any Plextor PX-716A Users that do not have this issue please jump in.

Neil: Yes I got the latest flash from plextor.

More info: dbPoweramp player, and CD input both see the drive.

06-03-2005, 05:04 PM
latest drivers?

06-03-2005, 06:04 PM
Do you get to the point where you can click on Burn CD and do you get an image like the ones below?

If so, what options do you have showing? What I have there is OK for me, for my 2 drives.

06-03-2005, 08:22 PM
Yes I get to that point.
What I have is like the picture on the right, with my drive correctly identified.
When I click burn it gives a progress window, the drive spins up, and after 3 seconds I get the error message.
From that point the drive seems hung, and I must restart to get the drive to eject the unburned cd.


06-04-2005, 12:05 AM
Wait, what data mediums are you using? CD-RWs, or CD-R's? What brand?

06-04-2005, 12:08 AM
Yes I get to that point.
What I have is like the picture on the right, with my drive correctly identified.
When I click burn it gives a progress window, the drive spins up, and after 3 seconds I get the error message.
From that point the drive seems hung, and I must restart to get the drive to eject the unburned cd.

I would try one other thing, though that's part of dMC Audio CD Input, but it may solve this problem too.

Start dMC AUdio CD Input, click the big Options button, check that you have to proper drive selected there and click Advaced. Look at CD Communication and maybe change it to something else. Test the new setting by inserting a cd and trying to see if it reads it.

Another thing is you may want to try a fresh blank cd, as sometimes it may appear that nothing was written on it but it might have started writing to it, which will make it unusable thereafter.

06-04-2005, 12:00 PM
Is it the only cd drive on the system? how does it connect? as a slave drive?

06-04-2005, 04:22 PM
Neil, I have used other software with this new drive and had 100% success. I'll look at some other blanks and give them a shot. Thanks!

Christinas, I looked at those settings....I'll give that a shot but I don't know what they do, I'll do some research on it. My current settings are..Cd Communication ASPI and Command set MMC, does that match yours? I'll try some new settings and get back on Sunday with results.
For each attempt I have used a new blank cd, I have quite a stack of the ones I have tried. For what its worth I used one of the attempted discs in Easy Cd to make sure it could be written and was successful. Thanks!

Spoon, Thanks for jumping in. It is the only optical drive and it's on its own IDE channel, that is channel Two. It is set as Master/Single Drive. Channel One, Three and Four are all HDD and I reviewed my jumper settings and they appear correct. The previous CD-RW Drive shared that channel with a DVD-RW and both are now gone. No changes were made to any other hardware during that swap. I have reviewed Bios also. No Overclocking. I have done alot of searching and found that Plextor has had problems writing with this drive BUT the revision levels in question are at 4.0, the newest flash was 7.0 and I could find nothing above 4.0 criticizing the drive. The problems mentioned were not tied to one software product or another, it was an across the board problem and was (I think) more likely related to Mobo/Chipset. (Via KT400 here for what thats worth)

I may post in other discussions tonight to fish for current Plextor PX 716A users and direct them to this thread.

Spoon I am ready to return the drive and try another, what a let-down this high $$ Plextor has been. I am a long-time user and you are, hands down, Da Man.

06-04-2005, 05:37 PM
The setting that works for me is SCSI Driect Pass Through . Windows Internal Limited also works. ASPI doesn't work. My drives are an LG CD burner and a Liteon DVD burner. Same settingss work for both.

06-04-2005, 05:40 PM
Note that if you are not using dMC Release 11.1 Release Candidate 1 (linked below), these settings will be called something along the lines of "2000/NT Communication" and "2000/NT Build-In (Limited)".

06-04-2005, 06:10 PM
CD burning will not use any settings from Audio CD input. It is strange...there are other programs running in the background which might be jumping in on the cd writer, windows has its own cd writer and itunes has a cd writer - both of these are services in XP and can be safely disabled (if you know what you are doing).

06-04-2005, 07:42 PM
Wait, Spoon, do you mean through Task Manager?

06-04-2005, 08:09 PM
Probably not. The Windows CD recording disabling is done in the Service Control applet. I don't know about iTunes, but I don't htink it involves the Task Manager.

06-05-2005, 01:41 PM
IMAPI Cd-Burning COM service was set to manual. I tried Automatic and disabled. I noticed that the dbPoweramp CD writer did not depend on this service.
I have disabled several un-needed services to maximize efficiency, too many to list. I know just enough to be dangerous. I have had my current services settings for a long time and burned with the old drive using dbpoweramp CD Writer.
I keep a pretty tight grip on what loads at startup, and I reviewed what processes were running after startup. There are no unrecognized processes running, and nothing to do with cd/dvd authoring.

Looks like the drive is the culprit to me. I'll let you know if swapping again makes any difference.


06-05-2005, 03:09 PM
Just got back from Best Buy, Swapped Plextor for Sony DRU-720A.
Works perfectly. No other changes made to any settings or software.
Got $10.00 back and a $30.00 rebate slip to boot.
So much for dreaming about a plextor for years...

Thank you all for trying to help me. One of the best things about the dBpowerAMP suite of software is this forum and its members. No burner, or punk at best buy ("You have to use the software that came with it"), is going to keep me from using the best music software in the world.

07-09-2005, 12:28 PM
Sidenote-ive had 2 px-716a go bad within a few weeks of purchase,run the self test to be certain the 716 is working properly.