View Full Version : Help with ASPI

01-02-2005, 10:00 PM
Cd writer does not recognize my drive. I ran the aspi check & found that nothing was installed. I ran the installation & now 2 files are not installed - the wowpost.exe & winaspi.dll are not installed. I have the files in the download but don't know where to put them. Can anyone help???

01-03-2005, 03:12 PM
There are various ASPI installers out there, try a few before getting technical.

For XP you shouldn't need ASPI.

01-03-2005, 07:37 PM
Thanks for the help Spoon. I am running xp - but have tried 3 different 3rd party burning programs & none of them will work. The Sony product that came w/the computer works fine but I have a lot of ogg files that I'd like to burn cd's from & the bundled software does not support ogg. The ASPI layer was the only thing I found in the help files that seemed probable. Any other suggestions would be greatly appreciated.

01-03-2005, 09:36 PM
When you hit the Burn button in dCW, do you not get a window where you can select your burner drive?

Otherwise you can convert your .ogg files to .wav and then use your other buring program to burn yorur audio cd's.

I am wondering though if your burner has been properly installed.

Click on My Computer > right click the cd burner drive giving trouble > Properties> Hardware > find your drive again there > properites > properties and explore all about the drive. You can try Trobleshoot, but it may not lead anywhere conclusive. Perhaps you need a driver update too.

01-03-2005, 10:19 PM
Thanks Christina -- yeah, i get the window to choose the drive & then I start the burn & in a few seconds a window comes up that says the drive is not ready & the files have not been written. However after that I am not able to reuse the disks - so something has been written on them. I checked out the drive in windows & all seems to be ok - i didn't find anything unusual or drivers needing updated. I'm stumped.........any other ideas??

01-03-2005, 11:36 PM
OK, I had this before, but not necessarily from dCW, rather from any other cd burning program I was using (e.g. Nero)! I think it was related to my defining a drive image thing - so I got rid of it. I can't remember all that well, it was some time ago, after I'd installed my DVD burner in place of the regular cd-rom. I was then left with a cd burner and a dvd burner. It took a while to get them sorted.

This was a time where I was installing and uninstalling all sorts of stuff.

I can't even remember how and where I defined the drive image - I guess I'm aging faster than my pc! :p

01-04-2005, 04:18 PM
Also try selecting a slower burn speed.

01-04-2005, 08:38 PM
thanks spoon & christina -- i did try slowing down the burn time to 12x from 24x -- this is a brand new computer -- grrrrr --and i'm always older than my computers!!!!!! any other ideas?? i haven't tried any other ASPI downloads -but you are saying that shouldn't be a problem w/xp - right spoon? is it worth spending time even looking at that as a solution??

01-05-2005, 04:12 PM
You could try and verify ASPI is working by using 'dMC CD Input' >> options >> advanced

01-05-2005, 08:14 PM
ok spoon i check in the options - advanced section & it lists ASPI under cd communication. does this mean then that it is working fine?

01-05-2005, 08:44 PM
ok spoon i check in the options - advanced section & it lists ASPI under cd communication. does this mean then that it is working fine?
If you can rip cd's that way, then it works. Otherwise you have to change it to another option.

01-05-2005, 11:03 PM
ok - i could not rip w/the ASPI setting. I can rip w/the nt2000 i/o setting. now - does this setting help w/the writer also? because after I changed it and found it able to rip - i went back to the writer & it still did the same thing & did not write. If not - how do get that setting to be the default - or is that what I want to do??? where do i go from here???
thanks for all the patience & help.

01-06-2005, 12:28 AM
also - would changing the command set help the writer any???? i tried a couple different ones & it didn't help - should I keep trying that?

01-06-2005, 04:11 PM
Command set will not help, if CD Input cannot rip with ASPI then ASPI is not working (you can run the checking programs on the support pages).

Also make sure you are logged on as Administrator.

01-06-2005, 08:22 PM
HERE (http://www.ncf.carleton.ca/~aa571/aspi.htm) is a kinda detailed explanation on aspi. Perhaps som burning proggie messed up aspi in your system? Then reinstalling it may help.

01-06-2005, 08:54 PM
thanks larry -- i have already read that page & installed the first ASPI files listed - in fact that is where i was when i began this thread. two of the files listed as needed for the ASPI layer are not installed & I don't know where to put them or if i need to try a different set of ASPI files. (see my first post)I tried just placing them in the windows systems folder - but i'm guessing that i also need to change something in the registration as well as having the files in the system folder. When I changed my settings in the configuration utility in db converter from using ASPI(as i described in my last post) the burner does work - but the cd writer still does not work. my question is whether or not that setting should make the cd writer work as well as the burner -- or am i back to where i started with needing to install the ASPI files??? hope this makes sense.

01-06-2005, 08:58 PM
It makes sense. I think your cd burner drive is not properly installed, or else the Sony program you have for it has messed up something.

I have several .dll file mentioning aspi:

01-06-2005, 10:53 PM
Try NeroInfoTool (http://www.cdspeed2000.com/files/NeroInfoTool_227.zip) to check what's wrong with aspi. On the other hand, make sure that your burning prog supports your cdwriter...

01-06-2005, 11:17 PM
thanks larry - thats a pretty cool tool! my ASPI installation is corrupted.