PDA

View Full Version : How do I disable .mpp automatic link ?



jimmi
07-19-2004, 06:09 PM
Hi,

I'm very happy with dbpoweramp, except that, when the musepack plugin is installed, he tries always to open automatically the microsoft project files (.mpp) for conversion, even if in the "file types" option of the explorer the mpp files are linked to the correct executable. The result is that the computer is blocked for some time until the program exit with an error. To be able to open the files from within the explorer I must then remove the musepack plugin, and install it only when I need.

I cannot find a way to prevent this automatic action: can anybody give an hint about ?

Thanks in advance
Jimmi

Spoon
07-20-2004, 07:24 AM
In the dBpowerAMP Audio Player, Music Converter, or Popup info in explorer?

xoas
07-20-2004, 12:16 PM
I suspect your problem is with the audio player (dAP). The problem arises because some Musepack files also have the .mpp file extension. First check the Musepack files you have. If any have the .mpp file extension change the file extension to .mpc or .mp+.
Then go Start>All Programs>dBpowerAMP>Configuration>File Associations. Scan down the list of file types until you come to MPP file. Uncheck the box. Click on OK.
Next, go to your Control Panel, click on Folder Options. Click on the tab that reads "File Types." Scan down the list of file types in your registry until you reach
MPP. If this shows MPP files as being associated with dBpowerAMP Audio Player, or if it shows anything else than Microsoft Project, click where it says "Change" and scan the list of programs until reach Microsoft Project. Then click on Apply and then close out that window.
That should fix your problem. If you have further trouble, please let us know.
Best wishes,
Bill Mikkelsen

jimmi
07-20-2004, 05:34 PM
I suspect your problem is with the audio player (dAP).
...


I don't have dAP installed ;)



...
Then go Start>All Programs>dBpowerAMP>Configuration>File Associations. Scan down the list of file types until you come to MPP file. Uncheck the box. Click on OK.
...


I can't find a "File Association" in anywhere. If I open the dMC configuration window, right at the end I have a list of installed input codecs, each one associated with a group of extension. Once the musepack plugin is installed it is associated, among the others, with .mpp files, but I don't have any means to change this association. :(



Next, go to your Control Panel, click on Folder Options. Click on the tab that ...
Then click on Apply and then close out that window.


I did this check already and it is ok. However any time i click on a MSProject .mpp file within the explorer, it stays for a while and then exit with the fake message:

Error: function play()
File uses Intensity Stereo, not supported anymore!
Please decode with command line tool.

Thanks anyhow Bill :smile2:
Jimmi

ChristinaS
07-20-2004, 07:28 PM
I have the beta 3 dMC and in the configuration, for Musepack, it is associated only with .mpc .

I see that at Codec Central, under Popular codecs, it shows Musepack associated to Formats .mpc, .mp+, .mpp.

I think that if you uninstall your version of dMC and download the beta 3 and install it, this will clear up this bad association.

Thereafter, if you ever need to decode a Musepack file with the extension .mpp, logically you could just rename it to extension .mpc and it will hopefully work.

xoas
07-20-2004, 08:44 PM
However any time i click on a MSProject .mpp file within the explorer, it stays for a while and then exit with the fake message:

Error: function play()
File uses Intensity Stereo, not supported anymore!
Please decode with command line tool.

Try opening your dMC Configuration (Start>All Programs>dBpowerAMP Music Converter>Configuration>dMC Configuration). Uncheck the box that says "'Convert to' on Explorer Right Click" and/or the box that says "Popup Info tips on Explorer". This may not have the effect we are looking for here but you could give it a try. Perhaps Spoon can shed further light on this.
Best wishes,
Bill Mikkelsen

jimmi
07-20-2004, 09:28 PM
I have the beta 3 dMC and in the configuration, for Musepack, it is associated only with .mpc .


Thanks Christina but doesn't work :( Did you installed the codec ? As long as I install the codec the associations are always the same.

I saw in the configuration window a "Smart Install Codecs" list but I ignore its purpose. When I try to convert some .mpc files dMC request me to install the codec.

At least I have the chance to test the beta :D

I think the problem is not dMC itself but the codec. I'm not an expert, but at this point I suspect that any action is necessary to take, must be taken before compiling the codec.

ChristinaS
07-20-2004, 09:45 PM
Thanks Christina but doesn't work :( Did you installed the codec ? As long as I install the codec the associations are always the same.

I saw in the configuration window a "Smart Install Codecs" list but I ignore its purpose. When I try to convert some .mpc files dMC request me to install the codec.

At least I have the chance to test the beta :D

I think the problem is not dMC itself but the codec. I'm not an expert, but at this point I suspect that any action is necessary to take, must be taken before compiling the codec.
Well, I didn't have that codec before, but now I do. So it is true that now dMC Configuration shows that .mpc, .mp+ and .mpp are all associated with Musepack (this wasn't the case before I installed the codec).

I went to look at Folder Options>File Types in WIndows Explorer and I found out that indeed mpc, mp+ and mpp are all associated with DMCCONVERT (I guess that would be dMC). So, from prior experience, I know you can change the file association there and specify MS project (whatever it's app name may be). If you have that installed, you can select it from the choice of programs to use for opening it with, or you can go through a rather it's a legthy (and cryptic) process to figure out what parameters to put in and for what function (open, edit, etc).

jimmi
07-20-2004, 09:48 PM
...
Uncheck the box that says "'Convert to' on Explorer Right Click" and/or the box that says "Popup Info tips on Explorer". This may not have the effect we are ...

Unchecking "Popup Info tips on Explorer" did the trick ! Thanks a lot Bill :smile2:

In fact the problem was with the left click, not the right ;) I cannot have the nice info popup, but at least I avoid installing and removing the codec everytime.

Jimmi

jimmi
07-20-2004, 09:54 PM
...
I went to look at Folder Options>File Types in WIndows Explorer and I found out that indeed mpc, mp+ and mpp are all associated with DMCCONVERT
...

In my file types .mpp are associated with MSProject, but the problem is not there; in my reply to Bill I believe is clear what's the matter.

Jimmi

ChristinaS
07-20-2004, 10:27 PM
In my file types .mpp are associated with MSProject, but the problem is not there; in my reply to Bill I believe is clear what's the matter.

Jimmi

This is weird. Like I said, I didn't have this problem in this manner, and I installed everythign except for MS Project itself. I run Windows 2000.

After Musepack, .mpp was associated with DMCCONVERT, so all I had to do was change that in Windows Explorer Folder options, and I never lost the other feature (from Powerpack) to select Convert or the other dMC related utilities by right-click.

Just curious, do you by chance have the Windows Explorer set to accept a single left button click for opening a file?

jimmi
07-20-2004, 11:27 PM
This is weird. Like I said, I didn't have this problem in this manner, and I installed everythign except for MS Project itself. I run Windows 2000.
...

Sorry Christina but I may have put you on a wrong way. In fact after your message a lamp lit in my mind ;)
To have the error it is enough to have the focus on the explorer windows and the mouse pointer on the MSProject .mpp file, without clicking. I immagine that at this point dMC try to open the file to get the data for the popup windows; in fact if I disable it I may overcome the problem.

My problem is that I cannot remove the .mpp association from within the musepack codec, therefore I must disable the popup.

I hope now is clear enough; thaks again to everybody :smile2:

ChristinaS
07-21-2004, 12:11 AM
Oh, I indeed understood it as you are explaining it. However I can't reproduce this at all.

Of course, this may be because I don't have MS Project so I cannot create genuine .mpp files. I am trying to fool it by renaming a .txt file to .mpp - no dice. Hovering over the file just says it's .mpp, nothing more. Double clicking asks me to associate a program, so in this case Muepack doesn't take over - so it's OK.

But, when I renamed a .txt file to .mpc and I hovered over it or right-clicked over it, I got a bad persistent error that ends up shutting down Windows Explorer and Active Desktop needs to be restored. That is explainable since the file isn't really an genuine Musepack .mpc .

Since I don't have MS Project, it is true that the association in the Folder view > File Types was initially with Musepack (after I installed that codec). I deleted it. I would assume that I could, upon installation of MS Project reset it to MS Project.

So yes, I'm getting an error, but it is not the same and it is explainable - though annoying.

I'd have expected you to get a similar error if you had acquired a Musepack file with the .mpp extension and attempted to use MS Project on it.

See, this is what gets me confused, and not being able to replicate it myself doesn't help. It's not that I don't believe you, I'm just wondering what is really happening there.

Can you try to reinstall MS Project perhaps?

It would be a shame to lose the pop-up information for all files for that.

jimmi
07-21-2004, 12:54 AM
...
But, when I renamed a .txt file to .mpc and I hovered over it or right-clicked over it, I got a bad persistent error that ends up shutting down Windows Explorer and Active Desktop needs to be restored. That is explainable since the file isn't really an genuine Musepack .mpc .
...
that is more or less what it happens to me: as long as I hover over the file the message appears and most of the time the explorer crashes.

...
I'd have expected you to get a similar error if you had acquired a Musepack file with the .mpp extension and attempted to use MS Project on it.
...
except that, to get the error with Project I have to double click...


...
Can you try to reinstall MS Project perhaps?
...

I don't think it would be helpful: I think the problem is coming from an interaction within the explorer and dMC when the latter tries to read foreign files (same as you got with text files).

Thanks ;)

m@c@ub@
03-26-2006, 06:48 PM
Hi,

I had the same problem (WIN2K + dbPowerAMP + MS Project) and I solved it with a little hack (proceed with care!):

1. Find the file [install path]\dBPowerAMP\Multiplayer\Input\in_mpc\in_mpc.dll
2. Make a backup copy of it in a safe place
3. Open it in a Hex editor (I used XVI32 from http://www.chmaas.handshake.de/ )
4. Search the file for the 'MPP' string (you will find 2 occurrences)
5. Replace each one for another string (I used 'MP@')
6. Save the file
7. Repeat this procedure for the files named in_mpc1.dll and in_mpc2.dll at the same folder
8. restart your computer

I hope this help

m@c@ub@