PDA

View Full Version : Skips, stutters, jumps when recording to WAV file



suthers
06-16-2002, 06:12 PM
Hi All,
I'm using the Aux Input to record from tapes, saving as WAV format. My machine is WIN95a, and I've updated DCOM, the common controls and Winsock2, but not the DUN yet. (I really don't like DUN1.3!)
When the recording is going on the sound from the speakers is perfect. When I play back the WAV file created it contains horrible skipping, stutters, glitches - just shocking. Other WAV files play back fine.
I'm wondering if there is a way to increase the buffers, or is this barking up the wrong tree?
Any suggestions welcome!

Shalom

Bill

Spoon
06-17-2002, 01:48 AM
Buffers will not help, as it has to stream it to hard-disk. Make sure that your Hard disk has plenty of free space, also defragment it before hand.

suthers
06-17-2002, 03:50 PM
Hi Spoon,

Thanks for the reply! I'm saving to an empty 2GB partition, so free space or fragmentation shouldn't be an issue.

When it's recording, the hard drive light gives a brief flick about once or twice per second. It's not on all the time.

Will it make any diference whether I'm saving to a primary DOS partition or an extended partition?

Shalom

Bill

Spoon
06-18-2002, 01:37 AM
No it shouldn't do.

Try using Windows Sound Recorder, that will tell you if your sound card is functioning as it should.

suthers
06-18-2002, 04:04 PM
Hi Spoon,

Thanks again :-)

Yes, the windows sound recorder works no problem. I'd be using it all the time, but it seems to be limited to 60 seconds length.

The sound card is a Creative Vibra128 PCI card. The creative sound recorder that came with it works OK 90% of the time, but still give some glitches in random places, though not nearly as bad as dBpowerAMP Aux Input.
I downloaded xmsdsk.exe & set up a 64MB RAM drive. I haven't fully tested it yet, but on the creative recorder it looks like it's going to fix the problem.

My issue then will be that I don't have enough memory to create a larger RAM drive, so will have to record each track manually & move the file out of the RAM drive for the next track. It was the dBpowerAMP Aux Input's ability to distinguish the tracks automatically that I was after! Just put the tape on & come back when it's done.....that's where I want to get to!

Any thoughts?

Shalom

Bill

Spoon
06-19-2002, 01:32 AM
Sounds like somthing is not working right. I would get a Performance monitoring program (to monitor CPU usage), it could be that some program is taking 100% of your CPU time.

suthers
06-19-2002, 07:18 PM
OK Spoon - I'll do that this weekend & post the results.....

Thanks again

Bill

PS
The machine is a Celeron 700MHz, 128MB RAM running WIN95a

suthers
06-27-2002, 11:19 PM
Hi Spoon,

Sorry for the delay - my wife is due for our first child in 3 days, so I haven;t had much time to play with the PC!

Using System Monitor, CPU Usage prior to recording starting was about 5%, while recording was 24%, so I thought that was OK. I pulled my PC apart & played around with the IDE configuration. Discovered that my older CD_ROM drive was not ATA compliant, and was slowing down comunication with the hard drive. Shifted the old CD_ROM onto a different IDE port & got the hard drive interface loading S.M.A.R.T. OK. This resulted in much better performance from dBPowerAmp Aux Input, but still skipping intermitently.

So I changed to saving to the RAM drive instead of the hard drive & it works flawlessly. Means I'm stuck with doing one track at a time, but it's better than nothing :-)

Looks like the speed of communication across the IDE interface is causing the problems - any ideas of how to solve it properly?

The motherboard is a Gigabyte VIA Apollo Pro family AGPset Socket 370, with ATA66 capability on IDE port 1. The hard drive is a 12 month old Seagate 20GB.

Shalom

Bill

Spoon
06-28-2002, 01:34 AM
You might want to look at different VIA drivers, and maybe disable DMA options (dma used to cause stutter on my playback of sounds).

suthers
07-09-2002, 09:30 PM
Thanks Spoon......now to reveal my own lack of knowledge, just what do you mean by DMA Options?

Shalom

Bill

PS
Is there a quick way to find out what version of Aux Input is installed on my system?

totalXSive
07-10-2002, 12:41 AM
I can't really tell you much about DMA, but to answer your other question, the version number of Auxiliary Input can be found by going to Start > Programs > dBpowerAMP Music Converter > Configuration > dMC Configuration.

If no number is listed, then you don't have the latest version. Otherwise it will tell you what version you have.

MODatic
07-10-2002, 05:12 AM
Spoon would be referring to the DMA checkbox that you would get under properties when you right-click on a CD or HDD drive under device manager. Usually it is a good idea to have DMA enabled as it speeds up access speeds as it buffers more with the ram. It can be very helpful as in my case, without DMA, a 12x10x32x CD burner was unable to write faster than 8x4x32x on a PIII 733Mhz with 256MB of ram on Windows 98SE or XP Pro. Worth enabling for all recent CD drives, though, definitely make sure that DMA is switched off for that older drive as it definitely wouldn't support it. Your HDD would support DMA since it is pretty new, if DMA isn't enabled for it, I recommend that you do enable it. DMA would definitely increase your IDE access speeds.

suthers
07-14-2002, 04:25 PM
Thanks for the extra info guys! I should have looked in configuration to check Aux Input myself hey....oh well, if we were all bright no-one would use forums!

I'm running WIN95a, and after looking intently for the DMA option & not finding it I went for a surf around the SeaGate site. Turns out that WIN95 only supports hard drives using DMA from OSR2. D'OH!

There are many suggested methods out there for upgrading OSR1 to OSR2 (not supported by Microsoft :-) ) Has anyone tried it & found out how many of your applications get killed by the process?

Mind you, Spoon has suggested turning DMA off, MODatic has suggested turning it on.....anyone else out there like to vote as to which I should be going for???

Shalom

Bill

suthers
08-04-2002, 05:06 PM
Hi Spoon & everyone else who posted info to help me!

I'm finally working, so I thought I'd post what I did in case someone else ever needs to know.

I had a look around my OS (win95a) and proved that it can't support DMA transfers to hard drives. That limits it to ATA33 maximum transfer speed. My BIOS and drive were set to ATA66, but I hadn't noticed any problems. Turned out this was because I had old VIA chipset drivers loaded. After updating the VIA chipset (ide controller etc) drivers things got very sick as the OS tried to talk ATA33 & the bios & drive tried to talk ATA66. To get things working again I removed the VIA IDE driver and using Seagate's ATA100.exe utility locked the hard drive down to a maximum of ATA33. This was detected by the BIOS which also slowed down, and I had everything working at ATA33. This was fine for everything except the sound work - the skipping on record etc was still there.

SO I got a copy of win95B and upgraded, installing over the top of my win95A version using the 'OEMUP=1' trick which worked far too good to be true & thus got DMA transfer capability. I then installed the latest VIA IDE driver & used ATA100.exe to set the drive to ATA66 (The fastest my current BIOS flash will support). This all went beautifully and I now have ATA66 transfers with DMA enabled and the recording works faultlessly. Playback is also improved greatly, and I can even play back with the on-access virus scanner set to scan all files.

So there you go. I ultimately put my problems down to a compination of WIN95A's ATA33 limitation causing the HDD access to be too slow, and the conflict between the drive/BIOS using ATA66 & the OS ATA33 causing brief 'hangs' in communication on certain data calls.

Thanks again to everyone for all the help!

Shalom

Bill