View Full Version : Sync problems using foobar mobile

07-02-2019, 04:02 AM
I have problems using the sync function with foobar mobile. When I setup the pairing it started syncing. The library was to big to finish in one run. But from now on I get status in foobar mobile toggling between: connected - transfering (always the same file, which seems ok in all other programs) - network error and after several retries disconnected. I restarted both devices several times without an effect. Both my PC (Win10 Home 1809, 64bit) and my smartphone (Sony Xperia H8324)have a good network connection, using WiFi through a AVM FRITZ!Box 6490 Cable.
Any additional logs, traces etc. I can fetch, to help tracking down this problem?
Regards Dirk

07-02-2019, 05:37 AM
What happens if you remove this one file? then try the sync.

07-03-2019, 06:10 AM
Thanks for the bug report.

Please post more information about the file which it fails to transfer: file format (FLAC? MP3), file size, etc.

To retrieve debug logs, follow my instructions here:

You can email any detailed information (debug logs, problematic file, etc) to me at peter@dbpoweramp.com .


07-03-2019, 01:22 PM
Hi Peter,

I've been going to write a post on my issues with the Foobar option of TuneFusion (attempted shortly after the last update), but have been otherwise occupied and went back to pulling the HD card from the phone, plugging it into a USB adapter and running the "local" version of TuneFusion to update it.

One issue with the current Foobar option is that it constantly restarts itself when it hangs/times out, the detail log gets instantly overwritten, TuneFusion always uses the same filename for the detail log in any particular sync. Perhaps you need a further debug option where you increment the filename or append a date/timestamp to avoid the overwrite. I was unaware of the log in Foobar, but unless that persists, I'm sure my logs from the TuneFusion attempts are long gone.

Basically, using the Foobar option, the sync keeps hanging, I suspect on the Foobar side first, from watching the display on the Android phone when it hangs. It just sits there saying that it is transferring (or saving, I don't remember now) the file until the PC end gives up and restarts. Then, after the PC side restarts, it will say network timeout, disconnect and reconnect and start again. Sometimes it syncs some files, from only one to a few hundred and then hangs again and restarts. Sometimes it gets to a file to sync and has to try a number of times before it successfully syncs.

I do have one m4a file that absolutely would not transfer (out of 60,000 total files). I even took the original file (it had started as a FLAC file, was previously converted to m4a using a different TuneFusion sync) edited the audio in an editor (trimmed a few seconds off the end) removed the embedded JPG cover art, changed the filename and ran TuneFusion (successfully) on the PC to make a new m4a (which plays fine on the PC) and then tried to sync it to the Android Foobar. No dice. Weird. Anyway I have that file I can send you. I also have the non-detail sync log from that (over a week long off-and on, mostly during overnights) sync of the 60,000 files, which I can send.

My hope was that once I got the 60,000 files synced once into the Android, that the updates, typically a few hundred files or fewer at a time, would run better. But when I tried the next sync run to foobar shortly after the overall sync, it exhibited the same behavior. Overnight, it had only synced a few dozen of the files. So I went back to removing the SD card from the phone and using the USB adapter to update. (And BTW, the "unsyncable" file syncs fine in that mode.)

I do occasionally see an issue even using the USB adapter, but I think that is self inflicted. Every now and then, I'll get an error message about being unable to save a temporary file on C:, disc full? for a bunch of files and then it will run OK for a while before doing that again. Now what I realized is that C: where the temporary files are saved is a pretty small (250GB) SSD, fairly full, so if things get behind in moving the temp files to the USB connected SD card, it could actually be filling up the C: drive. (of course it could also be the firewall/antivirus blocking the write...) In any event, is there a convenient way to tell TuneFusion to use D: (a several terabite raid 1 array) instead of c: for its temporary storage? My short term solution has been to run the sync again, the failed files synced the second time.

FYI, on the Android, I'm saving the synced files on the SD card in a folder at the root called music. On the PC end, the m4a files live on the aforementioned D: drive.

I'd like to get this to work, so updating the phone would be automatic and prompt, but I just have had too many other items on my agenda to keep dealing with it, so I temporarily gave up.

What files would you like me to send and how? I might have to Dropbox stuff and send a link, the some files may be too big to email.

07-10-2019, 11:37 AM
Thanks for the details

Overwriting of logs has been addressed for upcoming TuneFUSION update, detailed logs of sessions from last 1 month will be retained.

Please send the offending file which would never transfer to me ( peter@dbpoweramp.com ) for analysis. Dropbox link is fine if the file is too large for emailing.

07-12-2019, 10:28 PM
Hi I downloaded the update, and ran it this evening to sync my master files (two large directories, one almost all FLAC and one all old m4a files) to my directory prepared for later sync with phone. I continued to get occasional unable to save temporary files errors. Originally I thought this was because the "C" drive used for temporary storage is a smallish SSD, and might be temporarily filling up. But that doesn't seem to be the issue, as I still got the errors with only a few syncs needed. The first time I ran the sync, I got a bunch of unsynced files. Immediately ran it again and got (as I recall) 8, then ran the sync a third time, and everything synced. Haven't tried the Foobar sync with the new software yet.

Computer, rather robust desktop running W7 64 bit, up-to--date. Source files come from a QNAP NAS which at times can be slow to respond. (the Z Drive) Destination (D drive) is a directory in a raid 1 array in the W7 machine, mostly empty. Antivirus is Macafee All files are converted to m4a in the sync DSPs are replay gain and trim silence. File Name is Sub Path/Source Filename. There are somewhat over 60,000 files in the source directories.

I have placed in Dropbox (linked to Peter) the two logs from today's sync to the D drive. I have also placed there the "unsyncable to Foobar" m4a file I had mentioned earlier. This file syncs fine if I remove the SD card from the phone and use a USB adapter with the computer, but would never sync through Foobar into the (android) phone.

Finally I have included the log from my attempt to sync the 60,000 m4a files through Foobar to the phone, showing the many times it hung and restarted. I had to keep quitting, as I had to use the phone during the day. But the sync finally got to the end, with some errors, some of which were bad files in the source 60,000. After sorting that out I ran the sync again and finally got all the files synced. My hope was that with the giant sync done, the updates of a few hundred files would run OK, but, as you can see, it still hung every few transfers. So I finally gave up and synced the SD card in the USB adapter as I had been doing, using a different sync in Tune Fusion. That ran OK except for the same problems I have had with "unable to save to temporary" errors as discussed at the beginning of this reply.

I hope this helps you.


07-15-2019, 01:07 PM
Thanks for the details.
I sent you a link to a new beta build with attempted fixes, please check your email.