View Full Version : Asset UPnP on QNAP - Audio format streaming - FLAC to WAV

01-01-2019, 09:00 AM

I've got Asset R6.1 running on my QNAP NAS.

I've got my CD's ripped and saved as FLAC files.

I wanted to test whether playback sounded better letting Asset send FLAC files as they are stored or whether converting them to WAV first before serving them up to my UPnP renderer was best, or if it made no difference.

So to start with I went to the Asset Configure page and down to "Audio format streaming", and changed FLAC from "as is" to "as WAV".

Using foobar2000 with a UPnP browser plugin on my PC I can play the files from Asset fine - and in the File Properties I can see File names like "d-8065562640914796164-co0B0B406D4D608D17.forced.wav" with the PCM codec etc. And they play fine.

However on my Logitech Media Server running on a Raspberry Pi (running piCorePlayer) - I can see the Asset files in my Remote Music Library (UPnP renderer) and add them to the playlist of a Squeezelite player (another Raspberry Pi running piCorePlayer), but they won't play at all.

Has anyone ever tried to do the same, and either had the same issue or found a way around it?
Any suggestions for fixing this issue please?


01-01-2019, 11:18 AM
The Logitech possibly cannot play wave over upnp, try forced as LPCM.

01-01-2019, 02:36 PM
The Logitech possibly cannot play wave over upnp, try forced as LPCM.

I just tried that. I get the same behaviour - I can't play FLAC's as WAV or LPCM from Asset UPnP, but it does play them when converted to MP3. Or as basic FLAC files.

01-02-2019, 04:58 AM
That is all it can play then.

01-03-2019, 05:06 AM
That is all it can play then.

I created an actual WAV file, saved it the QNAP NAS, and added that folder into the Asset library.

I can play the WAV file if I navigate to the mounted QNAP NAS drive from my Logitech Media Server (LMS), but I can't play the WAV file over UPnP. Must be a limitation of LMS.

Thanks for responding anyway.