View Full Version : dMC-R15.3-Ref-Registered.exe will not start

07-30-2015, 09:28 AM
I installed a new hard disk on my PC, so I need to re-install dbpoweramp I purchased in 03-2014. I downloaded today the dMR-R15.3-Ref-Registered.exe from the dBpoweramp website, but when I click on the downloaded file, nothing starts. when I look at the programs/processes running (via CTRL-DEL, task list), I don't see any program like dbpoweramp running or installation program...
what can I do to re-install my purchased product ? I'm working on PC with Windows Vista

07-30-2015, 09:47 AM
Are you sure you have completely downloaded the dMC-R15.3-Ref-Registered.exe? Try it again and check the filesize, should be 26.3MB

07-30-2015, 05:50 PM


for some this update also stops the installer from running.

08-02-2015, 02:07 PM
I have the same problem on 8.1.

I purchased the registered product a few weeks back but wasn't worried when opening the file did nothing as the product worked. My trial period has ended now, though and the registered version won't install so I can't use it.

The file looks the correct size (I tried downloading again too) and I uninstalled the update above from 8.1 but it still won't work.

Any more ideas so I can install the product?

08-02-2015, 04:23 PM
What is the exact filesize?

What antivirus are you using?

(the vista issues is limited only to vista)

08-03-2015, 04:36 PM
Thanks for the reply. During debug I have discovered other times my PC is having issues so think the problem is on my end. Am going to refresh or reset windows and try again.

08-05-2015, 05:03 AM
Works fine now so must have been corrupt windows.