PDA

View Full Version : No CD Drive found



Fedor
12-14-2014, 05:36 PM
Hi,

I already searched within this forum, but found nothing that helped my registered Poweramp-copy to identify my external DVD-drive. I am using Windows 8 on an Asus including a a flash-drive (C) as well as a HDD (D). The external DVD-drive (E) is a Samsung SE 208. I already tried the different "Communication"-methods within the CD Ripper's options - didn't work. Also running as an Admin didn't help. There's no anti virus program installed other than the regular Windows firewall for which I explicitly listed CD Ripper as a "trusted app".

This is the Debug message:

Using SCSI PassThrough [clCDDA::SetCommunication]
->-> [frmMain::RefreshTrackListing]
Quitting Meta Thread: Quit
->-> [clCDDA::ReturnDriveList]
Got drive C:\ ** not CD Rom, type: 3 [cddaSCSIPassTru::FillDriveList]
Got drive D:\ ** not CD Rom, type: 3 [cddaSCSIPassTru::FillDriveList]
Got drive E:\ ** not CD Rom, type: 2 [cddaSCSIPassTru::FillDriveList]
<-<- [clCDDA::ReturnDriveList]
<-<- [frmMain::RefreshTrackListing]

Can you help ?

Thanks in advance

Spoon
12-14-2014, 05:47 PM
The type number corresponds to:

http://msdn.microsoft.com/en-us/library/windows/desktop/aa364939%28v=vs.85%29.aspx

DRIVE_REMOVABLE 2
The drive has removable media; for example, a floppy drive, thumb drive, or flash card reader.

It should report:

DRIVE_CDROM 5
The drive is a CD-ROM drive.

Like every CD drive does, reporting its self as a Thumb drive means CD Ripper will not detect it.

Fedor
12-15-2014, 07:09 AM
Is there a chance to get the thumb drive being identified as a category 5 CD-ROM drive ?

Spoon
12-15-2014, 08:39 AM
Not sure why it is registering as such, perhaps get a different CD drive?

Fedor
12-15-2014, 09:10 AM
I just realized that the drive has the option to switch into "Samsung Connectivity Mode", which makes it acting like a thumb drive for Samsung TVs for media playback. This probably was the default setting. Switching back to "ODD-mode" should solve the problem. Thanks for the help anyway. Next time I'll read the user manual first :rolleyes: