PDA

View Full Version : Gapless ripping



lg.lindstrom
11-23-2011, 10:53 AM
Hi

I am ripping my CD's using DbPoweramp and a utility decoder for ripping to flac and .cue sheets. Output after is one big .flac file and a .cue file.

My player is Squeezebox Duet, contains a player and a controller.

As I understand the Squeezebox combination should be able to play gapless content.

Two problems *smile*
1. Some of the ripped CD's, not all, shows up as a single track the in the controller although the CD contains multiple tracks. Playing it,, shows that all tracks is in the flac file. The ripping procedure is done with same parameters, nothing is changed, for both cases.

2. Regardless of point 1,, the Squeezebox seems not play gapless. But it should.

My question to the this group:
- Is there something I have missed when ripping my CD that can have influence on my problems.

I would gladly provide you with some examples just to get some help from you.

//lasse

Spoon
11-23-2011, 01:55 PM
if the file is a single file then every player would play it gaplessly.

Also all rippers on the planet will rip tracks gapless (if the CD was a live gapless CD). If an ordinary CD then gaps tend to be at the end and beginning of the track, you would have to rip to single files and use the DSP effect delete silence.

garym
11-23-2011, 03:33 PM
Hmmm, not sure why this is not working. I have lots of SB players and I rip all my CDs to FLAC with dbpa. And everything that is supposed to play gapless, plays gapless as expected. I don't do anything special in ripping. That said, I do NOT use CUE sheets. In the very old days these were sometimes needed to get gapless. This is no longer true. Ripping as regular separate FLAC tracks (or LAME MP3 for that matter) will play gapless on most players, certainly including squeezeboxes. Personally, I see no benefits and nothing but extra trouble when trying to rip a CD to a single track with CUE sheets.

Be sure to check in SqueezeBox Server that you don't have crossfade turned on. It should be OFF.

BrodyBoy
11-23-2011, 03:40 PM
Personally, I see no benefits and nothing but extra trouble when trying to rip a CD to a single track with CUE sheets.
Agreed. That seems like an approach that has nothing but potential limitations and problems. Using the more universally-recognized method of ripping separate track as separate tracks would resolve this whole issue.

lg.lindstrom
11-24-2011, 07:48 AM
I will check the settings in Squeezebox.

lg.lindstrom
11-24-2011, 07:56 AM
if the file is a single file then every player would play it gaplessly.

Also all rippers on the planet will rip tracks gapless (if the CD was a live gapless CD). If an ordinary CD then gaps tend to be at the end and beginning of the track, you would have to rip to single files and use the DSP effect delete silence.

Hmmmm am I using the wrong terminology here???

For example, Genesis and The Lamb Lies Down on Broadway, contains many tracks that fades in and out on each other. When the first song getting to the end you can hear the next song start. For a short while you can hear both songs simultaneously.

I my case, after ripping, there is a silence between the songs.

Regardless the terminology,, how do I achieve this behavior,,, and what is the correct terminology.

garym
11-24-2011, 08:43 AM
Hmmmm am I using the wrong terminology here???

For example, Genesis and The Lamb Lies Down on Broadway, contains many tracks that fades in and out on each other. When the first song getting to the end you can hear the next song start. For a short while you can hear both songs simultaneously.

I my case, after ripping, there is a silence between the songs.

Regardless the terminology,, how do I achieve this behavior,,, and what is the correct terminology.

Gapless is the correct terminology. What you are wanting should happen automatically. Try ripping one of these CDs with dbpa creating separate FLAC tracks for each song. does this work?

For example, I can play the Beatles Abbey Road, certain Pink Floyd, or lots of live albums where one song blends into the other with NO gap between the songs. So you should be able to do what you want.

lg.lindstrom
11-24-2011, 02:37 PM
Be sure to check in SqueezeBox Server that you don't have crossfade turned on. It should be OFF

Where is the crossfade button????

I am running squeezebox server on a Netgear Ultra Nas. Verson is 7.6

lg.lindstrom
11-27-2011, 02:56 AM
Found the crossfade button, sorry about that.

So conclude the information I've got here.

- Gapless playing should work with Squeezebox regardless if I ripped to
a) one big flac file and a cue sheet
or
b) multiple flac files.

garym
11-27-2011, 06:25 AM
so conclude the information i've got here.

- gapless playing should work with squeezebox regardless if i ripped to
a) one big flac file and a cue sheet
or
b) multiple flac files.

yes!