View Full Version : Robot want initialize..

02-19-2011, 11:37 AM
Hi All

I just bought me a kodak G4 on ebay..
I have installed the amtren driver but I cant get it to work:

When I start ripping a batch I get the ULCLI Notification:

"Unable to initialize robot, shutting down (plese check the end batch button)"

When I run tests on the robot I get no result. It is unable ot load or unload.
I can manually put a cd in the drive and get it to test and verify with Accurate rip that the drive is working. So it is not the comport that is wrong, there is communication between the G4 and my computer.

When i do the tests in the configuration, it is unable to load or unload, when i do the prebatch test I get the following message:

VLast command did not fail or time out, not using skip value of failed...
CCommand Failed: C:X:30:2:ELast command failed or timed out, skip value is failed...
Notifying operator: Unable to initialize robot, shutting down (please click the End Batch button)...
Message to message file: [cancel batch]

Please help me!!

02-19-2011, 02:36 PM
Which Windows version do you have?

02-19-2011, 03:11 PM
Hi spoon

I have tried it on an xp-based system, (my workplace). But i also have both win7 64b computer and one that runs vista...
Should i try one of the others?

02-19-2011, 04:16 PM
A 32 bit OS should be the staring point for this driver, on Vista and Win7 run batch ripper (run as administrator). These are just guesses though.

02-20-2011, 08:43 AM
Ok when i try it on my vista pc I get the notice:

"unable to find com port COM1. ..."

I guess that is progress?
The drive still works, i can play a cd and rip one, test the drive with accuraterip.
When i look under the drives properties it says under location:
location 0.
I have tried changing the com port to COM0, but that doesnt help..
I hope you can help...


02-20-2011, 10:32 AM
The drive will be at a location, also a serial port is used, com0 is not valid as they start at 1 and go up.

02-20-2011, 11:11 AM
ok I have gone through the com ports.
It seems that port 3 is the one.

But still there is no action from my robot.
It just writes that it cant initiate robot..

when i test loading or unloading i get

Cancel batch

When i test prebatch i get

Unable to initialize robot, shutting down..

Is the robot deffekt?
Can i fix it? Or should i just send it back.

02-20-2011, 11:48 AM
You would have to try with some other software which is know to drive the kodak.

02-20-2011, 11:58 AM
any suggestions?
There is no cd with the robot.
I cant find anything about the robot online either..

02-20-2011, 03:27 PM
Never used one, sorry.

02-22-2011, 03:14 PM
Hi Kodak,

-please install the PL-2303 USB Driver (USB-COM Driver)
-the Amtren Driver do not work ! (i can send the right via Mail)
-Install the "kodak Driver"
-Set the right Com Port on the Batchripper config.

Thats all !