PDA

View Full Version : FLAC tag isue - Zen X-Fi2



Bacchus
08-07-2010, 09:16 PM
Hey,

(Note: All the music files referenced here were ripped from my CD's using one version of dbPoweramp or another. Currently I'm using 13.3 reference, and my FLAC codec is release 14. But some of the FLAC files were originally ripped using dbPoweramp 11. Not sure what FLAC codec version. The files were copied to the device directly using Windows Explorer.)

I have issue with my FLAC tags, or it may just be Creative being hosed. Anyhow, the issue is that when I add FLAC files to my player, the artist name shows up as "TIST=The Beatles" instead of just "The Beatles"If I copy MP3 files there, the "TIST=" doesn't show.

I tracked down a couple of threads on the creative forums about this, and this post:

http://forums.creative.com/t5/MP3-Players/X-Fi-2-firmware-1-12-08-march-2010/m-p/552802*blooper*M233122

Suggested it was an issue with the tag not being properly formatted as a VORBIS comment, but instead being an ID3 tag. It pointed to another thread here:

http://forums.creative.com/t5/MP3-Players/X-fi2-Firmware-Suggestions/m-p/547557*blooper*M231775

That claimed one way to fix it was using mp3Tag to re-write the tags. I couldn't figure out how to just use it to re-write the existing tags, as opposed to changing stuff and/or importing data from the internet. Which I don't want to do.

So I did some searching here I found this thread:

http://forum.dbpoweramp.com/newthread.php?do=newthread&f=10

Based on that and comments I found from you here:

http://www.hydrogenaudio.org/forums/lofiversion/index.php/t32390.html

and here:

http://www.hydrogenaudio.org/forums/lofiversion/index.php/t68944.html

It seems like dbPoweramp is already writing the correct format. So first I confirmed that my setting for FLAC id tags were Vorbis Comments. (I had never touched the settings, but just in case.)

Then I tried running the ID Tag Update utility codec, with no options selected. Just trying to make sure they copied and re-written. Hopefully removing any issues that might be version related.

Unfortunately that didn't change a thing. The artist I tested was still showing up as "TIST =<artist name>."

I wondered if you had any other possible suggestions, and/or a contact with Creative who might know of a formatting issue or whatever. Other than that the tags work fine in both WinAMP and windows explorer. I'm going to try changing the ID3V2 Text encoding under FLAC from ANSI to Unicode-16 and re-doing the id tag update to see if that helps.

Thanks in advance, and sorry for the length of the post.

Bacchus
08-07-2010, 09:57 PM
The change to Unicode-16 didn't seem to have any effect at all. Still getting the "TIST=" prefix.

I know this is probably fairly X-Fi2 specific, but since at least some are reporting resolving the issue by re-writing the tags as vorbis comments, I have to think there might be some slight offset issue or something.

Thanks again.

DazBYorks
08-08-2010, 06:03 PM
Hi,

Simply hitting save in mp3tag with the track selected should rewrite the tags. If not, make a minor change, save, change it back and then save again. Before you do open up the "Extended Tags.." dialog and see if anything looks untoward.

It does seem curious that part of the tag name is being matched - having problems with spaces in the tag names would be easier to understand.

Daz

Spoon
08-10-2010, 04:21 PM
The unicode options are only for ID3v2 tags, not for vorbis comments.

It sounds like a bug in the Zen, as no other program or device seems effected by this.

melbe
09-02-2010, 08:39 AM
Hi,
I found a solution and just wanted to share my workaround in case you still didn't manage to make the Zen X-Fi2 show proper tags and a cover picture on FLAC Files!

You can read my post here:
http://www.anythingbutipod.com/forum/showthread.php?p=496219*blooper*post496219

Hope this helps!
melbe:smile2: