View Full Version : Amtren elite micro configuration

05-04-2010, 09:59 PM
I recently won and received this (http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=120563556504&ssPageName=STRK:MEWNX:IT) unit.

I plugged it into my Win7 x64 machine and several drivers installed from Windows Update without issue. Device manager indicated a "USB Serial Port (COM3)" device. I downloaded the latest CD and Batch rippers, plus the Amtren driver. All installed, no problem. The changer is recognized as a Plextor drive.

In Batch Ripper Configuration, when I click Configure, the default CLI strings use COM1, which I changed to COM3. When I click Test then Start Test I see an "Unable to find com port 'COM3'. Exiting ULCLI in 5 seconds..." dialog.

I need to verify if my unit is functional or not soon so I can deal with the eBay seller in the worse case.

I tried STF for every search term of the error message I could think of. I've read the help files in the Batch ripper directory. Be gentle - I'm very new to ripping with a robotic changer.

This unit should work, right? Any help is much appreciated.

05-05-2010, 03:11 AM
Sounds more like a driver issue than a device issue, if com3 is created then it should exist.

05-05-2010, 09:17 AM
These are the two drivers that are installed.

Nothing is banged out.
Could I use a dumb terminal program to tes functionality of the COM port? That is, if I manually send some command over COM3, should I expect a reponse?
Is there some other app, perhaps from the manufacturer, that I could run to test basic functionality?
Is the driver set above that which is expected?
Anything missing?

05-05-2010, 02:43 PM
Yes, open the com port with a dumb terminal, it is a good test.

05-05-2010, 09:27 PM
I installed HyperTerminal and opened COM3. HyperTerm says "Connected", but when I handshake with a couple ENTER keys nothing is echoed back (and I'm not sure what to expect here).

Is there some string I should be able to send to the COM port that will get a response?

05-06-2010, 12:15 AM
I'm getting closer. I installed Flexware from Amtren's web site. I ran the utility app and it successfully ran the arm through its range of motion, loading a CD and depositing it on the output spindle. This app showed the changer on COM3.

Still couldn't get Batch Ripper to do anything productive. I found this thread (http://forum.dbpoweramp.com/showthread.php?t=16330) of Brendan's where he talks about dumb terminal commands.

Hyperterm said it couldn't open COM3. I messed around further with Flexware and had it reset the changer.

Thereafter, I got Hyperterm to open COM3 and was able to send any of the single-letter commands, receiving back valid responses from the unit!

When I try to test the unit in Batch Ripper now it still says that it can't open COM3. I have closed Hyperterm so that the connection on COM3 is closed.

At least Hyperterm showed me that the unit is good and it really is on COM3.

Any further advice for getting Batch Ripper working?
Do I need to configure anything about the loader in CD Ripper?

05-06-2010, 04:14 AM
Try running batch ripper with compatibility mode of XP, I think that Brendans drivers do not work in Vista / Windows 7.

05-10-2010, 05:31 PM
Using compatibility mode worked; thanks for the suggestion, Spoon. I opened the Properties dialog of each executable (load, unload, etc.) and changed compatibility mode to XP SP3. Now CD's rip almost as expected.

The only trouble left is the disc rejection scenario.
1. Disc rips until rejection threshhold (too many bad frames) is met.
2. Tray opens, arm picks it up, tray closes, disc is dropped on the table.
3. Arm now raises above tray, tray opens, and arm lowers into empty tray.

The arm then pauses at this last position and I eventually get an error from batch ripper that there's been an error in controlling the unit.

Thanks for your help thus far, Spoon.

05-11-2010, 03:32 AM
What is the exact error message shown please?

05-30-2010, 03:36 PM
Title of the dialog: "ULCLI Notification (message repeats every xx seconds until dismissed)"
Error message: "Problem with robot on port COM3 for drive H, shutting down..."

Clicking OK yields a dialog that says, "Finished Batch Rip".

With a terminal program I can open COM3 and send all of the following, which return a success code, X.
C - (re)Calibrate (aka Reset)
V - Send me the "Signup String" (identifies the device to the software)
I - Insert (move from input to drive tray)
A - Accept (move from drive tray to output)
G - Get (pick from drive tray and hold)
R - Reject (with disc already held in picker, place on table underneath position of drive tray, requiring disc tray to be closed)

Any ideas?

05-31-2010, 04:11 AM
I am sorry I do not know.