View Full Version : Batch Ripper in Wine - Eject Problems

01-28-2010, 06:43 AM
I'm trying to building a ripping pc with a goal to rip cds with a average time ~1min / cd:

5 x SAMSUNG SH-S223L/BEBS SATA 22X DVD RW Internal Drive
2 x SEAGATE ST3750641NS Barracuda ES.2 750GB SATA
ASUS M4A78T-E AM3 AMD 790GX ATX motherboard
PHENOM II X4 965 3.4G

Ubuntu 9.10
Wine 1.0.1
dMC Release 13.3 downloaded trial 1-23-10
Batch Ripper Release 1.3 downloaded trial 1-23-10

Batch Ripper has proven to me that it will meet my time requirements and the audio quality of FLAC combined with the AccurateRip and PefectMeta I am ready to register today and start batch ripping, but I have ran into some problems. I can't get the Eject After Rip in CD Ripper and the Auto Eject in Batch Ripper to happen when the rip is complete. Any Ideas? I'm not sure if it is Wine Config, the Profile, Batch Ripper Config or what? I'm also having problems permanently configuring all 5 cd drives in the Wine Config?

CD Ripper Profile - Eject After Rip - Checked
Batch Ripper Config - Auto Eject - Manual Load - Selected

Batch Ripper is the only program open all 5 audio CDs rip in ~3min and then nothing, no eject.

Any help would be much appreciated, thanks, Dale

01-28-2010, 06:50 AM
It is likely that Wine is not passing through the SCSI eject command.

01-28-2010, 07:29 AM
If Wine is not passing through the SCSI eject command, does anyone have any ideas to impove this? I have questioned the Wine Config during my troubleshooting of this issue. Should I turn to the Wine Forums? I have read that other users are using Batch Ripper in Wine. Any advice on permanently configuring multiple cd drives in Wine would be awesome! Dale

01-28-2010, 08:13 AM
Try in CD Ripper the eject button, does that work?

01-28-2010, 07:07 PM
I wanted to double check before I answered, but in CD Ripper the eject button does not work. At one point it may have worked once or twice. I think I have something incorrectly configured in Ubuntu 9.10 or Wine 1.0.1 or both. Any ideas?

01-29-2010, 05:09 AM
Sorry no.

02-28-2010, 06:56 PM
Well... I Had a nice long post all written out after the first time trying to make DbPoweramp eject a disc in CD ripper failed... Then I tried it again and it worked. No dice in batch ripper though. However, I believe I've figured out why it doesn't work.

Dbpoweramp will eject the cd, but only after it has been unmounted outside of Wine :(. This only happens (sometimes) with the CD ripper, and hasn't happened much at all after I tried it a few more times. I guess it's hit or miss? With Batch Ripper it happens every time (more about why later).

So, if you can't get the software to eject the drive after ripping, you can unmount the drive and then tell DbPoweramp to eject the drive and it will work like a charm. That's not going to work very well with batch ripping.

I think it shouldn't be too difficult to write a simple script that will unmount the drive, but the trouble would be how to trigger that script? The other problem is I don't think Batch Ripper ever releases control of the drive, whereas CD ripper does (once the disc is ripped, it's done with the drive).

It also appears that whether or not this would be successful would revolve around how Batch Ripper treats the cd drive in question after it has been "ejected." I don't think Batch Ripper ever surrenders control of the drive, and as a result, I think what one ends up is this won't eject disc 1! (http://http://ubuntuforums.org/archive/index.php/t-251848.html). FYI that thread is a goldmine as it goes through all sorts of ideas about ejecting drives, however it isn't tailored towards the idea of ejecting them several hundred (or at least dozen) times in rapid succession.

Basically, even if your configuration allows the drive to eject the disc, it won't work in batch ripper because it appears the drive is always in use, even when it's not (which actually makes sense as it's going to read the disc as soon as you put another one in). I could be wrong about some of this..

03-08-2010, 02:26 PM
Hey thanks!!!

I'm still working at it. I have my machine over at a friend's now and he trying somethings. I agree if you unmount the drive in linux the eject does works, but not all the time. I'll post a better update once I have change to talk with my friend.

03-19-2010, 05:38 AM
Some good progress, here is the current status:
Trying Fedora 12 and using XFCE desktop which seems to be easier to leave the DVD drives alone than Gnome
Installed dBpoweramp 13.4 as root and then ran the program as root
Had to create some symlinks to .wine/dosdevices/ (I will post more details later)
CDGrap works better, the CD Ripper eject button does work now!
Eject After Rip works!

Started testing Batch Ripper installed as root and ran as root
In Batch Ripper no eject!

For the config I have both of the following checked/selected:
CD Ripper Profile - Eject After Rip - Checked
Batch Ripper Config - Auto Eject - Manual Load - Selected

Is this correct?
Any ideas why the eject would be different for Batch Ripper then CD Ripper?

03-19-2010, 06:29 AM
Have a look at cd ripper >> options

What is communication set to?

03-19-2010, 05:59 PM
SCSI Pass Through (SPT)

03-23-2010, 06:13 PM

Should we try something else?

Cound the problem be the UNLOAD.EXE?


03-24-2010, 03:33 AM
I do not know where the problem lies. Possibly unload.exe

03-24-2010, 06:14 AM
Here is some more info...

Tested Unload in the batch ripper config.
It ejected.
Running Program: "C:\Program Files\Illustrate\dBpoweramp\BatchRipper\Loaders\Au to Eject - Manual Load\UnLoad\UnLoad.exe" --drive="J" --logfile="C:\users\root\Temp\dBBd509.tmp" --passerrorsback="C:\users\root\Temp\dBBd50a.tmp"
Testing Complete

Batch ripper config can eject OK.
Batch ripper can't.

Hope that helps?


In batch ripper config, there's a Load CLI and Unload CLI.
They're grayed out. Looks like where I'd put an eject command.
It's in the drive config.
But, we could put 'eject /dev/sr0' or something in there.
Is that an option? How do we go about doing that?

Thanks so much for all your help!!!

03-24-2010, 02:40 PM
It has to be on drive letter, ie J in your example.

03-26-2010, 05:28 AM

In Batch Ripper Configuration when I edit the Loader Configuration the Unload CLI Test works for all 5 drives they each eject every time I test them. When I run the Batch Ripper all 5 CDs rip but Batch Ripper hangs at the end and no Eject, any ideas why?


03-26-2010, 06:03 AM
Potentially because batch ripper have the drives open and the eject which is separate tries to open the drive as well.

03-26-2010, 06:40 AM
How do I resolve this, it is the last issue?

03-26-2010, 08:21 AM
I do not know how you can.

03-29-2010, 06:26 AM

If I can't get Batch Ripper eject working in Wine, is there an easy way to do a Auto Rip on Disk Insert in the dBpoweramp CD Ripper?


03-29-2010, 06:35 AM
No, we cannot do this with our metadata which is inplace.