View Full Version : Custom Containers

12-24-2009, 08:21 AM

Is there any way without re-tagging to get Asset to support a custom container? I know it supports custom tags, but that's not exactly what I need.

I've written a proxy to allow Asset to be picked up as WMP on the Sonos controller. To work correctly I have to reconfigure the Asset browse tree, as the Sonos is looking for containers in response to some of its searches and items in response to others further down the search path. Whilst I'm able to reconfigure the tree (and Asset works as WMP on the Sonos controller with full album play etc), that obviously means that other users of Asset within my household (e.g. on the PS3) then also have to suffer the same tree. It would be great if I could create a dummy Sonos container with the tree structure I want inside, and use that for Sonos and the normal tree for everything else. I can create the tree, but I don't want to have to tag every item as Sonos to get them to be returned on browsing - I know that's the right answer, just wondered if there was any alternative, such as creating a dummy root (all the containers within the Sonos container are standard containers)?

One more question - do you intend to make Asset behave as WMP in a future Release (at least as an option), so that the Sonos controller can pick it up directly?


12-24-2009, 06:05 PM
I do not think there is an obvious way of doing a custom container.

I am reserved about emulating WMP, two reasons for this:

The original sonos controller, worked almost 100% correctly, there were a few things that could be done better and sonos hinted they were interested in helping complete this.

Fast forward 9 months and the new sonos release is locked to WMP, if that was not bad enough, WMP12 is a step back on WMP11 in UPnP compatibility, it is a real bastardaztion of the standard - almost like Internet Exploerer 6 (or was it 5) corrupted the web standards. Who knows given time, WMP12 might support UPnP as it should do...if anything Sonos and WMP are quite apt partners ;)

12-31-2009, 06:25 AM

One more related question - does a reconfigure of the Asset browse tree survive a reboot? I'm running Asset (free) as a service on XP Pro SP3, I rebooted the machine and it's lost my changes to the tree.

12-31-2009, 11:58 AM
Yes as it writes them to %appdata%\

12-31-2009, 12:21 PM
I've made the changes again.

I have an empty directory uMediaLibrary in %appdata% for the logged on user.

I don't have any file containing the changes in the uMediaLibrary in %appdata% for the NetworkService either.

Am I looking in the wrong place for the file containing the updated tree?

12-31-2009, 12:25 PM
Sorry, an update:

AssetUPnPDefinedBrowseTree seems to contain the updates I made a week ago, with a timestamp of a week ago. The updates may have been in there when the computer was restarted, but they didn't appear in advanced settings under configuration.

12-31-2009, 03:03 PM
You are running Asset on the local account?

12-31-2009, 05:22 PM

01-01-2010, 06:28 PM
Make sure the user account has admin rights as Asset Control is elevated to run, you can go back to normal user after running.

01-04-2010, 06:08 PM
Sorry, may have misunderstood you earlier question about how I'm running Asset.

I'm running Asset as a service. I've tried running Asset Configuration both as the user (who is an administrator) and as the administrator - I've made changes to the tree but they aren't reflected in \Documents and Settings\NetworkService\Application Data\dBpoweramp\uMediaLibrary.