View Full Version : Asset UPnP Documentation

12-14-2009, 04:27 PM
Where do I find Asset UPnP documentation?

(I've been trying to get it to work for several days with little success.)

12-15-2009, 04:54 AM

12-15-2009, 08:50 AM
Thanks, I'm going to try to figure this out myself.

12-15-2009, 09:48 AM
Thanks for the info (I'm addicted to dBpoweramp).

Sorry, can't figure out what is wrong.

I installed as recommended, "Local Account", it worked (played on Denon), then it disappeared (from Network and Denon).

I tried configuration "Service," rebooted, it worked and sounded great. Then it disappeared again from Windows Network and from my Denon.

I checked the Forum and followed the instructions here:

... and checked Windows Firewall per another thread. Since I installed while on vacation on a public network and my network is private, I changed Firewall settings to private only.

It worked, then disappeared.

I decided that I should stick with the "Local Account (Recommended)", rebooted and it worked and then disappeared.

Then I punted, uninstalled, started from scratch and went through the whole scenario all over again.

I've done this at least six times (lost count). Sometimes it works as "Local Account," but it changes back to "Service". Is Windows doing this? Sometimes it shows up as another library in WMP, but then disappears.

AssetUPnP Status: Library contains 2136 tracks, 168 albums.
Whenever I see AssetUPnP on my network, it works on my Denon.

- Windows Task Manager.
Asset-UPnP.exe System
Asset-UPnP.exe User

- Windows Firewall (all checked)
Asset UPnP
Asset UPnP TCP
Asset UPnP UDP

Current Configuration:

- Asset UPnP (Installed; registration pending successful install; Asset config "Service"; Windows config as Auto Start & login Local System)
dBpoweramp Registered Reference 13.3
- Windows 7 Ultimate 32-bit
- WMP 12
- Sony VGN-AR690U
- Denon AVR-3808CI

12-15-2009, 03:34 PM
Restarting Asset would probably fix the disappearing Asset, how long does it take to disappear?

12-16-2009, 12:25 AM
Just lost my explanation. Is there a way to save drafts or keep the Forum from logging out on me?

Had to change to local acct. Asset showed up in WMP, Net and Denon, but not tracks in Denon. Although there are one to six copies of each track in WMP's Asset library. Restarted, rebooted, etc. with same result.

I could offer more details, but I just lost thirty minutes of typing (I'm slow) and it is way past when I need to call it a day.

12-16-2009, 12:28 AM
Quit WMP and restarted immediately and Asset is gone just that fast.

12-16-2009, 05:06 AM
Try disabling all Firewalls as a test.

The Denon might only display tracks it can play, try adding a mp3 to the library.

12-16-2009, 08:42 PM
I disabled: Windows Firewall, Microsoft Security Essentials Virus Protection and Windows UAC. Asset-UPnP.exe is running in Windows Task Manager, but doesn’t show up in Windows Network Explorer or WMP. Throughout all the scenarios, WMP shows up on the Denon and plays as it has for twelve months. I tested one track to be certain (successful). I stare at the PC screen for a minute trying to figure what to try next. I look up and Asset UPnP is listed on the Denon. Before I can blink, it disappears.

Not knowing what to do, I preformed an unrelated update to my download mgr, which forced a reboot. Upon logon, Asset is shows up on Denon before I have time to open Task Mgr & Network Explorer. Then WMP shows up on the Denon. A moment later, Asset disappears.

I tested this: rebooted, login, observe Asset on Denon, observe WMP on Denon, observe Asset disappear.

I tested again, reboot, etc., playing one track from Asset on the Denon as soon as it showed up. When I backed up the menu, Asset was no longer listed as a media player and not in Network Explorer.

I tested again, reboot etc., playing one track in Asset ASAP. Then, I played an entire album different from the first track I played. While playing, Asset wasn’t displayed in Network Explorer or WMP, but was displayed in Task Mgr.

While writing this, I listened to one album, quit, backed out of Denon menu and Asset remained a listed player. Switch to TV, then back to Net Audio and Asset is no longer listed.

Could it be in contention with something else?

PROGRESS: This evening, I’m not changing anything, it comes and goes ON THE Denon list, but is staing on Network Explorer and WMP Library. However, WMP will no longer play it - “ Windows Media Player cannot play the file. The Player might not support the file type or might not support the codec that was used to compress the file.”

It seems to be scanning again. Now some tracks are listed up to fifteen times!

Note that there is almost a one minute gap between tracks when playing from Asset, but not when playing from WMP.

Windows file sharing encryption is set to 128-bit, not 40-bit or 56-bit.

Denon AVR-3808CI requirements seem OK to me.
With the AVR-3808CI’s network audio playback function, connection to the server is possible using one of the technologies below.
• Windows Media Player Network Sharing Service [I can see this running in Task Mgr.]
• Windows Media DRM10
WMA 32/44.1/48 KHZ 48~192 KBPS .WMA

My Setup.
Sony VGN-AR690u (Wireless)
Windows Ultimate 32-bit
D-Link Xtreme N Gigabit Router DIR-655
D-Link Xtreme N Duo Wireless Bridge/Access Point DAP-1522
Denon AVR-3808CI (Bridged)

12-17-2009, 02:20 AM
Can you test it without the bridge? wireless and bridges don't really go together, and can cause some problems with some devices (intermittently). For example, if my DLNA server is behind a wireless bridge, my XBox will sometimes see it, but usually wont. The issue is that the wireless bridge is actually not a true transparent bridge, and will only show a single MAC address regardless of what is behind it (it may be possible to configure which MAC address is cloned on the bridge).

If you want more information on the above, have a look here, under limitations:

Although that link is for a specific product, the limitation is in the WiFi protocol and will, to some extent, affect all wireless bridges.

Now, having said all that, given that WMP also loses sight of Asset-UPnP (I assume you mean on the same PC), its probably not bridge related.... but wireless bridges are less-than-perfect, so if its easy to try without... worth a shot!

Lastly, I have a somewhat similar set up. My denon also shows both WMP and Asset-UPnP in its list, but I don't have asset randomly disappearing. Have you tried using a UPnP controller program (like Cidero) to send tracks from your PC rather than using the painful denon interface?

12-17-2009, 09:22 AM

Yesterday I returned router and bridge to factory defaults and configured both from scratch. Then I deleted the HOMEGROUP Win7 asked me to create.

I have to restart Asset every time I want to listen to it, but that works (as designed?).

I created a [Title] container under Genre and a [A-Z] container under title. After a restart, that works. I checked Audio Type Exclude for every type that the Denon doesn't play even though my library is entirely WMA lossless, restarted, etc. and Asset still plays.

Now, I'm getting excited.

Spoon, you're the incredible man.

Thanks for the comments. I have one cable that may reach, but this would not be a permanent solution for my home. D-Link literature has always said that the better solution is to purchase another DAP-1522 and configure as an Access Point wired to the router in order to create a 5GHz wireless net. My home is full of 2.4Ghz and X-10 devices, so this has my interest. I will read the link later today. Any comment for now?

Also, I will look into Cidero. I didn&*blooper*8217;t know such a thing existed. However, Asset has never disappeared from the Denon interface without having first disappeared from Windows Explorer Network.

Thanks very, very much.

I became partially, temporarily disabled four years ago. I took a planned early retirement for a career change, but the recession and recovery led me to work full-time on recovery. Spending more time at home would have been hardly bearable except for the whole new world you have opened to me.

Wear Helmets!

12-19-2009, 08:57 AM
Two days later and Asset UPnP is still working.

My suspicion is that deleting the Win7 Homegroup fixed this problem.

12-19-2009, 09:16 AM
Should not effect UPnP.

12-28-2009, 05:48 PM

The problem reappeared last week. I wired everything (no wireless) and it made no difference. I noticed another thread mentioned trying FLAC.

I ripped a dozen holiday albums in FLAC and no problems for a week! (I haven't opened WMP12 in a week.)