View Full Version : wrong path in registry

11-10-2009, 03:40 AM

I am testing the Asset UPnP server for my home media network and I had problems to get Asset working.

I installed the Asset UPnP server with my admin-account on my WinXP machine. But I do not want to run the Asset UPnP server with admin-rights. When I start the configuration tool with user-rights I get an error that the file "AssetUPNPDefinedBrowseTree.txt" cannot be accessed. The problem is that the config tool tries to access the file inside the admin home directories which is not allowed to the normal user.

When I change the path in the registry to the user home directories everything works really fine!!

Another problem is after rebooting the PC. The path in the registry is automatically restored to the admin home directories where the file "AssetUPNPDefinedBrowseTree.txt" cannot be accessed.

Is there any solution to the problem? Or has any other the same problem?

Best Regards


11-10-2009, 04:54 AM
Run it as the local account, not as a service (which would be an administrator account).

11-12-2009, 08:03 AM
Hello Spoon,

Now its ok, when I boot the PC with my user account and Asset upnp server starts with the local account.

But I believe it goes wrong when I boot the PC and log in with my admin account. Asset upnp server starts automatically and uses the local account, which is the admin account now. Afterwards when I switch to my user account Asset upnp server has a wrong path in the registry. Probably this was the procedure which caused my problem.

Could you confirm this behaviour? Is there a possibility to prevent the start of Asset upnp server when logged in as admin?

Best Regards