View Full Version : Win2k CD ripping/converting limited to Admins??

05-03-2002, 03:18 PM
(please see my own reply, but still not a solution in the next post.)
with dMC 8d I can currently only rip files off of a CD when my login is part of the admin group of the Win2k SP2 machine.

I usually have my users limited to the windows default PowerUser group. I don't want to allow full access to our workstations just so they can rip tracks.

Troubleshooting steps. Using my test user who is part of the PowerUser group - when selecting a track in the windows explorer and going through the Convert To option box, I get the following error: "The file 'D:\Track03.cda' could not be opened.
Read Table of Contents failed - audio disc in drive?" from dMC

logging out, logging in as admin, adding the user to the admin group, logging out and logging back in as the test user: everything works fine. reversing the process making the test user only a PowerUsers results in the same error.

The output destination is on a seperate drive/folder with Full Permissions for Everyone. And the test user can create and delete files in that destination folder.

what's happenin?

05-03-2002, 04:04 PM
I never used the dMC Audio CD Input program in the past, only used to use the windows explorer since I have 0 interest in CDDB. I found the help file on that program, but....

When using the "dMC Audio CD Configuration" shortcut and setting it to "2000/NT Device IO (Limited)", the setting doesn't take when I click OK. Going back into it, it's alway the non-limited selection - and the ripping error still occurs when using the windows explorer method.

When using the dMC Audio CD Input program and clicking the Advanced button in the Options screen, I can select the "2000/NT Device IO (Limited)" option and the tracks show up in the list. I can then even convert them. But when I quit the program and start it up again, the setting doesn't stick and I must go back to the Advanced Options and again select "2000/NT Device IO (Limited)". Too much of a pain...

What is "Limited" and why must dBpowerAMP require admin privilages when previous version of dMC and other rippers don't require it. I know that in order to burn one must have admin, but to rip?

05-04-2002, 04:07 AM
You must have settings that prohibit programs from writing to the registry, that is where this setting is stored.

If you are using device IO ripping windows XP/2000 requires that you be administrator.

05-06-2002, 10:00 AM
I don't have any programs that keep me from writing to HKCU. The problem exists on two seperate machines. My admin machine and a machine that has a fresh install of Win2k SP2 and Office 2k. Niether allow me to keep the 2000/ NT Built-In (Limited) setting. It doesn't matter if I'm logged in as a Power User or Admin.

Manually changing the value of HKEY_CURRENT_USER\Software\Illustrate\dBpowerAMP\C D-Communication from "2000 / NT Device IO" to "2000/ NT Built-In (Limited)" has no effect either - the dMC Advanced Ripping Configuration dialog box always comes up with 2000 / NT Device IO set.

dBpowerAMP has no problems writing to its other registry values, as all other settings/paths that I have changed are remembered and I can see them in the registry.

05-06-2002, 11:48 AM
That is a confirmed bug, the next beta in the next two weeks will fix it.