View Full Version : cd ripper sees drive but batch ripper does not

08-30-2009, 08:59 PM
i have a dh-401s blu ray drive and a couple of liteon dvd drives on this machine.

CD ripper sees all 3 drives. It does list the blu ray as unknown/unknown but it's able to identify the disk in it correctly.

In batch ripper, the config screen shows just the two dvd drives, not the blu ray drive.

Any thoughts/advice?

08-30-2009, 11:50 PM
More info...

I used the regular (non-batch) ripper to get AccurateRip configured for the drives. Went through just fine for the two regular DVD drives.

The BluRay kept saying "your disc is not the same as the one in the database". This happened even if I used the same discs there were used to configure the DVD drives.

The firmware on dh-401s (LITEON... left that off the orig post) was the latest on the manufacturers site (CP56).

Am I fighting a loosing battle? I can dig up another DVD reader I suppose...

08-31-2009, 04:31 AM
There is an issue with the BR drive responding to the SCSI get information command, the goo news is I have a BR drive now which does the same, so can fix.

08-31-2009, 06:04 AM
Just fixed it (will release in R13.3) and potentially a new batch ripper - what nasty firmware these BR drives have - the scsi inquiry (which is the computer asking for the drives name) has to have an exact buffer length or it will not work, too large nothing is returned, which is not in the scsi specification...

08-31-2009, 06:33 AM
Batch Ripper (r1.3 beta) is here:


08-31-2009, 11:05 PM
Hey thanks for the quick response Spoon that was awesome :-)

So it definitely finds the drive now but it refuses to load the disc (says "loading CD" then moves to "Post-load waiting for CD"). The regular ripper (even though, of course, it does not know the name of the disc) still does load the disc (finds the right meta data, etc)

However, when I do AccurateRips config, it always says "This Key Disc cannot be used for offset detection (it does not match the one stored in AccurateRips database)"... tried several discs (oh.. guess I already said this in the original post :-) )

BTW, if it matters, it is detected as "ATAPI - BD O DH4O1S" which (fwiw) shows up in the AccurateRips DB

09-01-2009, 04:08 AM
Using Manual Load - Auto Eject?

Keep feeding CDs - the ones you tried cannot be used because there are other pressings of the same disc.

09-01-2009, 09:47 AM
Yes, Auto Eject - Manual Load.

I even tried the discs I used to sucessfully calibrate the other drives and it gave the same message.

09-01-2009, 03:09 PM
The other discs would give this result, if the other drives are exactly in the database.

I will investigate batch ripper.

09-01-2009, 05:24 PM
So someone has to have loaded an accurate rip of a given disc for that specific drive for it to be a valid "key" disc? I'll poke around the accurateRip site this evening to see if I can uncover anything.

09-02-2009, 03:28 AM
Just keep feeding discs until it configures.

09-02-2009, 09:54 AM
Ok will do... do I need to rip the disc or is it enough to have it go through the "config" step?

09-02-2009, 09:55 AM
Just need a track listing, no ripping.