View Full Version : Asset installing under different IP address

04-13-2009, 10:55 AM
I have a number of devices that use TCP/IP at home, so for security reasons I have my network run on a different network (i.e. not the usual 192.168.x.x that most peoples computers are on). All my systems run on a 10.1.x.x network.
I've tried different UPnP servers and they've worked fine (for example Nero MediaHome) but I was really excited to see Asset announced as it seems to have a fantastic range of audio codec support.
So, I tried installing Asset, but I couldn't find it from my PS3.
Invetigating further, while the particular computer I was installing it on has the IP address, the Asset UPnP server actually seems to be running from the IP address (I've confirmed using the netstat command on the machine I'm running Asset).
I don't know where its getting this IP address from (doesn't seem to be related to anything on my network) and the particular machine only has a single IP address configured (its not dual-homed etc.). Is there a configuration file I could modify to get it to run from the correct IP address?


04-13-2009, 05:31 PM
Open a command prompt and type


this will list all IP addresses on the system.

04-13-2009, 08:09 PM
If the machine does end up having multiple network addresses, change which one is the first one attempted to be used. To do this, go into your network connections from your control panel (Network Connections in XP, Network and Sharing Center in Vista then click "Manage network connections"). Go to the advanced menu (hit Alt to see this in Vista) then click "Advanced Settings". Set the top adapter to the one you want programs to use by default. Note that if you use any VPN adapters, they should be first.

04-14-2009, 05:04 PM
Thanks for the help. It turned out that a program I had installed was using VMware, which had installed a new network interface. I disabled that, made some changes to my firewall and can now see the UPnP server on my PS3 :D

Thanks again!