View Full Version : Asset R1 - WHS - Xbox 360 - Force Wave problem

03-27-2009, 05:18 PM
Installed release version 1 of Asset on my home-built WHS to stream to an Xbox 360. The default "Media Sharing" in WHS is set to off for all of music, photos, and videos. I've also stopped the Windows Media Connect Service.

I can browse all of my music fine from the Xbox 360 but any format I've tried that has a check in the "Force" option (ape, flac, m4a) will not play. It has the "crossed-out" symbol next to the title of the song and gives the "Unplayable Content" message when selecting it. Wave is selected for the "Force" option with every format checked except for mp3 and wav. I've tested mp3's and they play ok.

Also, "Apply ReplayGain" is checked and set to "Track Gain."

Any ideas what the problem may be?


03-27-2009, 05:22 PM
I tried disabling the "Apply ReplayGain" option and it didn't seem to make a difference.

03-27-2009, 05:39 PM
The XBox AFAIK cannot play wave, we have sniffed WMP when it serves a Wave file to the xbox and it seems to send LPCM, or raw PCM. It is also doing something very odd (in that the server WMP advertises a link for the audio, the xbox is adding something unique to that link, which suggests a program has to be programmed to know about the xbox, which is very un-UPnP alike), so it is an issue we know about and will fix when we are able to.