View Full Version : Extreme delay between tracks

03-25-2009, 08:39 AM
I am using Asset together with a Philips NP2900 network music player. I am experiencing a delay between tracks of approx 1 minute !

I have not touched any playbackk settings. This is using the out-of-the-box settings on a Windows Home Server.

Looking the the Windows task Manager, I don't believe this has anything to do with the performance of the system: it's doing nothing at all (CPU load ~ few %).

Any feedback is appreciated.

03-25-2009, 08:54 AM
As a test try Windows Media Player (11) and see if that can play without these delays (it should show Asset UPnP on the left side below library.

03-25-2009, 01:40 PM
Hi Spoon, thanks I will try that. Not sure whether that works on XP, but I'll give it a try. On the same WHS I'm running also TwonkyMedia 4.4.11, which doesn't show the issue.

03-25-2009, 04:13 PM
Unfortunately I can't get it running on WMP11. This seems only to work on Vista. I submitted a request to Philips whether this is a known or new issue with the NP2900.

On itlself strange however, that I'm getting this issue only with Asset, and not with other UPnP streamers. Asset is doing something really different than others..

03-25-2009, 04:51 PM
What type of files are you playing?

03-26-2009, 09:03 AM
Hi Spoon,

I'm running 'regular' MP3 files, which are converted using DBPoweramp to variable bitrate ~200 kbps, and using MP3TAGv2.42 got a proper ID tag, format ID3v2.3. No pollution with other tag data, just regular data (no itunes stuff etc).

Could it be that asset is waiting for certain data in a tag which is missing? Or doesn't it support ID3v2.3 properly yet?

03-26-2009, 11:14 AM
For mp3 files, if the WAVE/LPCM streaming option is not selected, we just send the whole file as is to the player, try the WAVE/LPCM streaming option for mp3 files, see if there is any difference.

03-26-2009, 04:50 PM
Hi Spoon,

This didn't make a difference. I noticed a "buffering" at the start (after a minute), so I knew the option was indeed effective.

Also I added an ID3V1 tag, next to the ID3v2.3 tag. Didn't make a difference either.

Somthing's putting a delay in the streaming, but don't understand what.

Right after a track is finished, I almost immediately see the contents of the next track. This means that the ID3v2.3, which is at the start of the file being transferred is already received. Hereafter it takes a minute (more or less exact) before the track starts playing, irrespective of the size of the MP3 file. On the WHS I do not spot any noticeable activity. The server is really doing "nothing".

04-03-2009, 04:31 AM
Hi Spoon,

I switched over to the new release 1.1, but that did not make a difference either.

I am not familiar with the UPnP 'protocol' if you may call it like that, but I will just making a guess/interpretation of what's happening.

When a new track is started (MP3), Asset starts sending the MP3 file to the device. The device notices reception of it, and the ID3v2.3 tag is immediately decoded (I see the track info on the display). I think the device is waiting for some command that start playing immediately, which is not received. After 1 minute a time-out occurs and the track starts playing anyhow.

My questions:
Do there exist multiple ways of indicating to a device that it is allowed to start playing a track? That my device wants to receive it immediately and that Asset is providing this after the MP3 was send?

Otherwise if you can provide me with some ammunition to go to the Philips service to get a better SW update, that would be fine with me as well. Now I only get the advise to stick with Twonky....

As said, I'm not familiar with the protocol, but I would guess it's something in this direction. I still would like to use Asset rather than Twonky, because the user interface of Asset is preferable for me (is really awesome). Additionally I find it integrating perfect in the WHS.

04-03-2009, 05:33 AM
The device would not read the id3 tag, as tag details are supplied by the UPnP program. The UPnP is very simple, asset will show to a player somthing like:


so the server asks for the file, if you knew the address (which you would not) you could even type into Windows explorer and it would offer to save the file, all very simple.

04-03-2009, 10:18 AM
OK Thanks. I know the IP address and port, so that would be easy :-)

What I then don't understand is why it does not start to play immediately when it receives the ID3v2.3 tag, which is placed at the beginning of the file, with the purpose of starting to play when it receives the first data.

Or do I think that it received already the tag because I see track info on the screen, while it actually did not receive the tag yet, but the info from the directory listing was used?

Could it be that Asset is not sending the ID3 tag info first?

I'm still puzzled why MP3's from Asset do not play right away while other UPnP player's don't have the issue. You are doing something different than others do, but what is it?

04-03-2009, 10:54 AM
Try a file with no ID tags...

04-03-2009, 05:07 PM
Removed tags from a file. Same result. 1 minute delay for Asset only.

04-07-2009, 05:09 AM
I'm about to give up on it. :cry:

From reading forum on other players/servers, I think it must be an incompatibility between Philips Streamium and Asset in the way how requests through UPnP are being done by the NP2900 AND handled by Asset. Maybe the clue is in the way how file are being send to the device. It seems like some protocol not properly being handled.

I don't have another device to try it out. Other have reported success.
They only thing I can do is check with other servers. None of the others (Windows Media Connect, Twonky, Orb), have any issue and play right away.

I would appreciate if you could get in touch with the Philips SW developers to find out what's the issue, that your competitors obviously already have resolved.

04-07-2009, 07:08 AM
Try enabling the WAVE streaming option, files are handled differently.

04-07-2009, 07:25 AM
Try enabling the WAVE streaming option, files are handled differently.

Hi Spoon,

You suggested that already last week. I tried it then (see my post). It does not make a difference. It waits a minute, starts buffering, and playing.....

04-14-2009, 04:07 PM
I've checked in the Philips forums. The most usable comments I received were:
So the same MP3-track plays fine with Twonky and not with Asset UPnP ? In that case it must clearly be the UPnP server.

It really looks like the underlying HTTP-server (serving the links that the Asset UPnP server is presenting to the UPnP Layer) has a buffering issue...

Maybe this is giving a clue.

04-14-2009, 05:11 PM
There is no buffering, any more so if you refresh this web page, it is a HTTP get and Asset serves them within mili-seconds.

04-15-2009, 09:36 AM
Hi Spoon,

OK then I will give up on Asset. If it won't work on my machine properly, I'll stick to what I have working now.