View Full Version : BatchRipper Hangs!

03-05-2009, 12:07 PM
When I'm ripping CD's using multiple players the BatchRipper stops responding ("hangs").

This happens when one of the current rip sessions encounter a bad CD with a lot of Re-Reads.

The background rips sessions finishes even if the BatchRipper hangs.

The machine is a Vista x64 system, clean only used with dbPowerAmp, no other software, with all updates installed. 8 core CPU with 4Gb RAM.

Using dbPowerAmp 13.2 (beta) and BatchRipper 1.2 (beta).

Any clue what the problem are?


03-06-2009, 06:08 AM
We will note as a possible bug to simulate and try to see if it can lock the batch ripper (none of my CD drives would lock like that).

03-15-2009, 01:29 PM
I'm have a lot of problem with the Batch Ripper hanging, it hangs at least 1 time every hour.

I'm tried everyting to find a work around, do you have any idea what to try?

It seams to hang when I'm having more then 2 rippers having re-reads at the same time, that means that if I'm ripping a bad batch of CD's I'm getting the hang more often.


03-15-2009, 04:18 PM
Are drives IDE (aka ATA), SATA, Firewire or USB?

If IDE, are they on the same IDE channel?


03-15-2009, 04:24 PM
Try not using Batch Ripper, instead have 2x CD Rippers running and see if one effects the other (on a working system, it should never).

03-16-2009, 03:01 AM
All drives are SATA-II.

I'v already tried running several CD Rippers without any problems!

I have 10 drives of the same modell, and are ripping 100 CD's / hour.

I have a Server motherboard with Dual Xeon 5420 processors (total 8 cores), 8Gb internal memory, running a 3Gb RAM disk (used as a temporary files, the temp ripp), 6 channel SATA on motherboard, 4 channel SATA on expansion card PCI-X.

The problem with Batch Ripper haning doesn't seam to be affected by the number of current Rips. If I only run 4 drives I still get the problem.

Note that it's only Batch Ripper interface that hangs, the CdGrab tasks finish even if BatchRipper hangs.

I'm made a dump of the hanged BatchRipper, is this something that can help in tracking down the problem?


03-17-2009, 10:06 AM
Any suggestions?

Shuld I revert back to non beta version of BatchRipper?

One obervation can be that the BatchRipper seams to hang (stop responding) when a CD has a high number of re-read sectors.


03-17-2009, 02:45 PM
Do you have the option to 'disable auto-run' set in Batch RIpper configuration?, if so uncheck it.

03-18-2009, 12:25 AM
Yes I do, I'll give it a try today. I'll get back with the result as soon as I can.

One other obeservation could be that the Batch Ripper seams to hang when there are 2 or more rips that are finished at the same time and at least one with re-rips.


03-18-2009, 09:47 AM
The disable of 'disable auto-run' did NOT help.

I'm more and more convinced that the hang is caused by more that 2 rips finishing at the same time.

I'm now keeping track of all hangs, I'm checking if 2 or more rips is finished at the same time and I'm checking if I'm having re-reads at the same time the Batch Ripper hangs.

Does this give any clues what the problem might be?


03-23-2009, 04:10 AM
The last 30 hangs, 2 or more rips has finished at the same time. So I'm almost 100% sure the bug has to do with this. I haven't found any other common thing during the last 30 hangs.

Any idea what to do? This is a realy big problem for us!


03-23-2009, 06:39 AM
We will give this propper attention this week, when the BR hangs, does the ripping process continue (are new discs loaded)?

Is the Manual Input & Review option enabled (to allow manual meta data input)?

03-24-2009, 06:56 AM
I'll try to give you as much help that I can.

When the BatchRipper process hangs, the CDGrab processes continue to run as expected and when a Rip is finished the CDGrab process terminates normaly.

The CD doesn't eject when the BatchRipper hangs.

Then manual review option is not enabled.

I have a process dump from when the BatchRipper has hanged, is this something that can help you in tracking down the problem?


03-24-2009, 11:18 AM
No, because the program would be waiting on mutexes of the system, which would not be in the dump.

03-25-2009, 08:19 AM
K1 please send an email 'batch ripper hanging' to:


03-27-2009, 04:00 PM
I've sent you a mail...