PDA

View Full Version : Correct settings in CD Ripper to use with Squeezebox 3 and ripping as flac please.



Gazza_UK
02-08-2008, 08:28 PM
Hi,

I am having no end of problems ripping to flac. Is there anyone using the Squeezebox 3 and ripping to flac please? I would really appreciate it if someone could point out exactly what all my settings should be.

I need to rip them in the correct file structure so that Slim Server reads it correctly. The current naming structure I am using is the default [IFCOMP][IFVALUE]album artist,[album artist],Various Artists[]\[album][IFMULTI] Disc [disc][]\[track] [artist] - [title][][IF!COMP][IFVALUE]album artist,[album artist],[artist][]\[artist] - [album][IFMULTI] Disc [disc][] - [track] - [title][]

Is this the right one to use for Slim Sever, as I am lead to believe it is quite fussy on how it reads them. It likes to have them set out in a certain way.

I would love to have all this set correctly for ripping my CD's as I fear its not bang on at the moment.

I get a lot of files that seem to rip OK but it says error at the end in a pop up window and shows the tracks. When I go to these tracks its normally the Tag information missing, also no Accurate info their either. Slim Server does not pick up on these and misses them out from the track listing.... even though they are on my PC and that folder. I thought by adding the ID tag by right clicking on the file, and adding artist/album/tack number etc... that after rescanning Slim Server it would pick it up again, but its still not there, so I am unsure what is missing from the file that Slim Server requires.

If anyone can help out it would be much appreciated as its all doing my head in now :cry:

Many thanks,

Gazza.

Spoon
02-09-2008, 03:47 AM
What is the exact error message shown?

Gazza_UK
02-09-2008, 08:43 PM
Hi,

Here is an example of errors after a CD has ripped. If I go back to these files now the tag info is missing. Even if I right click and edit Tag... and add artist name etc... Slimserver will not pick these tracks up.

If you could help with the correct settings it would be much appreciated.

Error ripping to FLAC, 'Track 1' to 'C:\Users\Gazza\Music\Various Artists\this is... Club Anthems\01 Apollo 440 - Krupa.flac'
Error opening file, check no other program has it open. [clDecoder::WriteIDTags]

Error ripping to FLAC, 'Track 2' to 'C:\Users\Gazza\Music\Various Artists\this is... Club Anthems\02 Ruffneck feat. Yavahn - Everybody Be Somebody.flac'
Error opening file, check no other program has it open. [clDecoder::WriteIDTags]

Error ripping to FLAC, 'Track 9' to 'C:\Users\Gazza\Music\Various Artists\this is... Club Anthems\09 Crescendo - Are You Out There.flac'
Error opening file, check no other program has it open. [clDecoder::WriteIDTags]

There is no other program open other than the CD Ripper... so not sure what it is referring to really.

Spoon
02-10-2008, 04:09 AM
Do you have a virus checker? if so try disabling it as a test.

Gazza_UK
02-10-2008, 07:13 AM
I closed down AVG Internet Security and I also stopped Slimserver running. Did that same CD again (bar 2 tracks which it struggles to read) and the ones above came back with no errors this time. So hopefully maybe that was the problem (fingers crossed).

I need to test some other CD's though.

However I still don't think the overall settings are bang on. It would be really nice to have all these set right and for me to redo my collection again, as I am not happy with how Slimserver is finding things.

Are you able to assist with the correct set-up in CD Ripper for flac/tags/ripping settings etc please?

Spoon
02-10-2008, 07:40 AM
It will be slumserver jumping on the files before they were ready.

You would have to deal with specifics when it comes to the slimserver, most systems of that type do not go off the filenames or folders, rather id tags.

Gazza_UK
02-10-2008, 09:23 AM
Many thanks for the feedback.

Are you aware of what the correct tags are by any chance?

Spoon
02-10-2008, 11:23 AM
Never used a slimserver.

Gazza_UK
02-10-2008, 01:10 PM
It would appear stopping Slimserver and AVG Internet Security is not the issue. As I have just ripped another CD again..... and get the same error messages as I listed above on 'x' amount of tracks (The CD is new). This is now causing serious issues for me... so unless someone can help resolve this then it looks like I just wasted 17.70 :(

Spoon
02-11-2008, 03:16 AM
You must have something else running which is opening those files as soon as they are created.